summaryrefslogtreecommitdiff
path: root/network/xrdp/xrdp.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/xrdp/xrdp.SlackBuild')
-rw-r--r--network/xrdp/xrdp.SlackBuild52
1 files changed, 40 insertions, 12 deletions
diff --git a/network/xrdp/xrdp.SlackBuild b/network/xrdp/xrdp.SlackBuild
index 24e9b2b690..b7a0ff2f0f 100644
--- a/network/xrdp/xrdp.SlackBuild
+++ b/network/xrdp/xrdp.SlackBuild
@@ -1,10 +1,10 @@
#!/bin/sh
# Slackware build script for xrdp
-# Written by Phil Warner <pc_warner@yahoo.com>
+# Written by Phillip Warner <pc_warner@yahoo.com>
PRGNAM=xrdp
-VERSION=0.4.0
+VERSION=0.4.1
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -15,8 +15,8 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
# If you have PAM installed and wish to install /etc/pam.d/sesman,
-# then run this script as: "USE_PAM=yes ./xrdp.SlackBuild"
-USE_PAM=${USE_PAM:-no}
+# then run this script as: "USE_PAM=YES ./xrdp.SlackBuild"
+USE_PAM=${USE_PAM:-NO}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
@@ -26,7 +26,7 @@ fi
set -e
-rm -rf $PKG
+rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
@@ -35,15 +35,22 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R a-s,u+rw,go-w .
-if [ ! "$USE_PAM" = "no" ]; then
- patch < $CWD/Makefile.PAM.diff
+if [ ! "$USE_PAM" = "NO" ]; then
+ patch < $CWD/patches/Makefile.PAM.diff
make
else
+ patch < $CWD/patches/Makefile.NOPAM.diff
make nopam
fi
# Fix path in what will become the init script
-patch -d instfiles/ < $CWD/xrdp_control.sh.diff
+patch -d instfiles/ < $CWD/patches/xrdp_control.sh.diff
+
+# Set LogFile at /var/log/sesman.log
+# Change LogLevel to INFO instead of DEBUG
+# Disable Root logins by default
+# Set user-specific RDP session script to ~/.xrdp-xinitrc
+patch -d sesman/ < $CWD/patches/sesman.ini.diff
make install \
PKGDIR=$PKG \
@@ -53,13 +60,16 @@ make install \
MANDIR=$PKG/usr/man \
DOCDIR=$PKG/usr/doc/$PRGNAM-$VERSION
-# Install routines for man pages and docs missing from Makefile
+# Install routines for man pages missing from Makefile
mkdir -p $PKG/usr/man/man5 $PKG/usr/man/man8
cp -a docs/man/*.5 $PKG/usr/man/man5
cp -a docs/man/*.8 $PKG/usr/man/man8
+# Make sure log directory is there
+mkdir -p $PKG/var/log
+
# Fix permissions from install
-chmod a-x $PKG/etc/xrdp/*
+chmod a-x $PKG/etc/$PRGNAM/*
if [ -e $PKG/etc/pam.d/ ]; then
chmod a-x $PKG/etc/pam.d/sesman
fi
@@ -69,12 +79,26 @@ chmod a-x $PKG/usr/lib/$PRGNAM/{Tahoma-10.fv1,*.bmp,*.cur}
mkdir -p $PKG/etc/rc.d
mv $PKG/usr/lib/$PRGNAM/xrdp_control.sh $PKG/etc/rc.d/rc.$PRGNAM.new
+# Move startwm.sh to a more sane location with a name that makes more sense
+mv $PKG/usr/lib/$PRGNAM/startwm.sh $PKG/etc/$PRGNAM/xrdp-xinitrc.new
+
+# Unfortunately, sesman.ini seems to ignore absolute paths for
+# startwm.sh, so we need to leave a link where it expects to find
+# the file under the program directory.
+( cd $PKG/usr/lib/$PRGNAM
+ ln -s /etc/$PRGNAM/xrdp-xinitrc startwm.sh
+)
+
# Let's not clobber existing configs
-cd $PKG/etc/xrdp
+( cd $PKG/etc/$PRGNAM
mv rsakeys.ini rsakeys.ini.new
mv sesman.ini sesman.ini.new
mv xrdp.ini xrdp.ini.new
-cd -
+)
+
+# Install the xrdp-xwmconfig utility
+install -D -m 0755 $CWD/xrdp-xwmconfig \
+ $PKG/usr/bin/xrdp-xwmconfig
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -88,6 +112,10 @@ cd -
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING design.txt install.txt readme.txt $PKG/usr/doc/$PRGNAM-$VERSION
+
+# Keep a backup copy of startwm.sh in the docs
+cat sesman/startwm.sh > $PKG/usr/doc/$PRGNAM-$VERSION/startwm.sh-example
+
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install