summaryrefslogtreecommitdiff
path: root/network/shorewall-perl/patches/patch-perl-4.2.10.1
diff options
context:
space:
mode:
Diffstat (limited to 'network/shorewall-perl/patches/patch-perl-4.2.10.1')
-rw-r--r--network/shorewall-perl/patches/patch-perl-4.2.10.191
1 files changed, 91 insertions, 0 deletions
diff --git a/network/shorewall-perl/patches/patch-perl-4.2.10.1 b/network/shorewall-perl/patches/patch-perl-4.2.10.1
new file mode 100644
index 0000000000..505bf3387d
--- /dev/null
+++ b/network/shorewall-perl/patches/patch-perl-4.2.10.1
@@ -0,0 +1,91 @@
+diff -Naur -X /usr/local/bin/exclude.txt shorewall-perl-4.2.10/changelog.txt shorewall-perl-4.2.10.1/changelog.txt
+--- shorewall-perl-4.2.10/changelog.txt 2009-06-18 07:04:06.000000000 -0700
++++ shorewall-perl-4.2.10.1/changelog.txt 2009-06-18 13:22:33.000000000 -0700
+@@ -1,3 +1,7 @@
++Changes in Shorewall 4.2.10.1
++
++1) Correct r2q Calculation
++
+ Changes in Shorewall 4.2.10
+
+ 1) Avoid 'large quantum' when adding HTB qdisc on fast interfaces.
+diff -Naur -X /usr/local/bin/exclude.txt shorewall-perl-4.2.10/install.sh shorewall-perl-4.2.10.1/install.sh
+--- shorewall-perl-4.2.10/install.sh 2009-05-29 18:34:08.000000000 -0700
++++ shorewall-perl-4.2.10.1/install.sh 2009-06-18 13:16:31.000000000 -0700
+@@ -22,7 +22,7 @@
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+ #
+
+-VERSION=4.2.10
++VERSION=4.2.10.1
+
+ usage() # $1 = exit status
+ {
+diff -Naur -X /usr/local/bin/exclude.txt shorewall-perl-4.2.10/releasenotes.txt shorewall-perl-4.2.10.1/releasenotes.txt
+--- shorewall-perl-4.2.10/releasenotes.txt 2009-06-18 07:04:06.000000000 -0700
++++ shorewall-perl-4.2.10.1/releasenotes.txt 2009-06-18 13:22:33.000000000 -0700
+@@ -1,4 +1,4 @@
+-Shorewall 4.2.10
++Shorewall 4.2.10 Patch release 1
+
+ ----------------------------------------------------------------------------
+ R E L E A S E 4 . 2 H I G H L I G H T S
+@@ -27,6 +27,14 @@
+ - Perl 5.10 if you wish to use DNS names in your IPv6 config files.
+ In that case you will also have to install Perl Socket6 support.
+
++Problems corrected in Shorewall-perl 4.2.10.1
++
++1) Users that set TC_ENABLED=Internal and have entries in
++ /etc/shorewall/tcdevices and /etc/shorewall/tcclasses may experience
++ startup error such as the following:
++
++ ERROR: Command "tc qdisc add dev eth1 root handle 1: htb default 12 r2q 20.8" Failed
++
+ Problems corrected in Shorewall 4.2.10
+
+ 1) A 'large quantum' warning log message during restart has been
+diff -Naur -X /usr/local/bin/exclude.txt shorewall-perl-4.2.10/Shorewall/Config.pm shorewall-perl-4.2.10.1/Shorewall/Config.pm
+--- shorewall-perl-4.2.10/Shorewall/Config.pm 2009-05-29 18:34:08.000000000 -0700
++++ shorewall-perl-4.2.10.1/Shorewall/Config.pm 2009-06-18 13:16:31.000000000 -0700
+@@ -312,7 +312,7 @@
+ TC_SCRIPT => '',
+ EXPORT => 0,
+ UNTRACKED => 0,
+- VERSION => "4.2.10",
++ VERSION => "4.2.10.1",
+ CAPVERSION => 40205 ,
+ );
+
+diff -Naur -X /usr/local/bin/exclude.txt shorewall-perl-4.2.10/Shorewall/Tc.pm shorewall-perl-4.2.10.1/Shorewall/Tc.pm
+--- shorewall-perl-4.2.10/Shorewall/Tc.pm 2009-05-23 08:58:07.000000000 -0700
++++ shorewall-perl-4.2.10.1/Shorewall/Tc.pm 2009-06-18 13:11:28.000000000 -0700
+@@ -787,7 +787,7 @@
+ my $devref = $tcdevices{$device};
+ my $defmark = $devref->{default} || 0;
+ my $devnum = $devref->{number};
+- my $r2q = calculate_r2q $devref->{out_bandwidth};
++ my $r2q = int calculate_r2q $devref->{out_bandwidth};
+
+ emit "if interface_is_up $device; then";
+
+diff -Naur -X /usr/local/bin/exclude.txt shorewall-perl-4.2.10/shorewall-perl.spec shorewall-perl-4.2.10.1/shorewall-perl.spec
+--- shorewall-perl-4.2.10/shorewall-perl.spec 2009-05-29 18:34:08.000000000 -0700
++++ shorewall-perl-4.2.10.1/shorewall-perl.spec 2009-06-18 13:16:31.000000000 -0700
+@@ -1,6 +1,6 @@
+ %define name shorewall-perl
+ %define version 4.2.10
+-%define release 0base
++%define release 1
+
+ Summary: Shoreline Firewall Perl-based compiler.
+ Name: %{name}
+@@ -62,6 +62,8 @@
+ %doc COPYING releasenotes.txt
+
+ %changelog
++* Thu Jun 18 2009 Tom Eastep tom@shorewall.net
++- Updated to 4.2.10-1
+ * Fri May 29 2009 Tom Eastep tom@shorewall.net
+ - Updated to 4.2.10-0base
+ * Thu May 07 2009 Tom Eastep tom@shorewall.net