summaryrefslogtreecommitdiff
path: root/network/mozplugger/mozplugger.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/mozplugger/mozplugger.SlackBuild')
-rw-r--r--network/mozplugger/mozplugger.SlackBuild78
1 files changed, 39 insertions, 39 deletions
diff --git a/network/mozplugger/mozplugger.SlackBuild b/network/mozplugger/mozplugger.SlackBuild
index 866d7d9140..731cbc1c97 100644
--- a/network/mozplugger/mozplugger.SlackBuild
+++ b/network/mozplugger/mozplugger.SlackBuild
@@ -1,69 +1,70 @@
#!/bin/sh
+
# Slackware Build Script for mozplugger
-# (C) 2007 Michael Wagner <lapinours@web.de>
-#
-# This program is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by the
-# Free Software Foundation; either version 2 of the License, or (at your
-# option) any later version.
+
+# (C) 2008 Michael Wagner <lapinours@web.de>
+# All rights reserved.
#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General
-# Public License for more details.
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Modified by the SlackBuild Project
-
-set -e
+# Modified by Robby Workman <rworkman@slackbuilds.org>
PRGNAM=mozplugger
-VERSION=1.8.1
-VERSION=$VERSION
+VERSION=1.10.0
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-CWD=`pwd`
+
+CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
DOCS="COPYING ChangeLog README"
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-cd $TMP || exit 1
+cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.* || exit 1
-cd $PRGNAM-$VERSION || exit 1
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-# Patch Makefile ($ARCH, /usr/man)
-if [ $ARCH = i486 ]; then
- patch -p0 < $CWD/Makefile_i486.diff || exit 1
-elif [ $ARCH = i686 ]; then
- patch -p0 < $CWD/Makefile_i686.diff || exit 1
-fi
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
-# Change installation prefix
-sed -i "s?\(root=\)?\1 $PKG?g" Makefile
-make linux || exit 1
-make install || exit 1
+make RPM_OPT_FLAGS="$SLKCFLAGS" X11=/usr linux
+make root=$PKG install
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
)
-( cd $PKG/usr/man
- find . -name "*.?" -type f 2> /dev/null | xargs gzip -9 2> /dev/null
- for i in `find . -type l` ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+mv $PKG/usr/share/man $PKG/usr && rmdir $PKG/usr/share
+gzip -9 $PKG/usr/man/man7/*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
@@ -73,10 +74,9 @@ chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/*
# Don't override custom changes to muzpluggerrc
mv $PKG/etc/mozpluggerrc /$PKG/etc/mozpluggerrc.new
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz