summaryrefslogtreecommitdiff
path: root/network/mozilla-firefox-esr/mozilla-firefox-esr.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/mozilla-firefox-esr/mozilla-firefox-esr.SlackBuild')
-rw-r--r--network/mozilla-firefox-esr/mozilla-firefox-esr.SlackBuild211
1 files changed, 0 insertions, 211 deletions
diff --git a/network/mozilla-firefox-esr/mozilla-firefox-esr.SlackBuild b/network/mozilla-firefox-esr/mozilla-firefox-esr.SlackBuild
deleted file mode 100644
index 9f7ba7c212..0000000000
--- a/network/mozilla-firefox-esr/mozilla-firefox-esr.SlackBuild
+++ /dev/null
@@ -1,211 +0,0 @@
-#!/bin/sh
-
-# Copyright 2008, 2009, 2010, 2011, 2012 Patrick J. Volkerding, Sebeka, Minnesota, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Modified by Niki Kovacs <info@microlinux.fr>
-# Modified by the slackbuilds.org project
-
-PRGNAM=mozilla-firefox-esr
-VERSION=${VERSION:-17.0.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) export ARCH=i486 ;;
- arm*) export ARCH=arm ;;
- *) export ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-MOZVERS=${MOZVERS:-esr17}
-RELEASEVER=$(echo $VERSION | cut -f 1 -d r | cut -f 1 -d b)
-
-# Try to be gentle to the compiler, no optimizations:
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "s390" ]; then
- SLKCFLAGS="-O"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O -fPIC"
- LIBDIRSUFFIX="64"
-elif [ "$ARCH" = "arm" ]; then
- SLKCFLAGS="-O2 -march=armv4 -mtune=xscale"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "armel" ]; then
- SLKCFLAGS="-O2 -march=armv4t"
- LIBDIRSUFFIX=""
-fi
-
-export PYTHON=$(which python)
-
-# PGO building
-PGO=${PGO:-no}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG/usr/lib$LIBDIRSUFFIX $OUTPUT
-
-cd $TMP
-rm -rf mozilla-$MOZVERS
-tar xvf $CWD/firefox-${VERSION}esr.source.tar.?z*
-cd mozilla-$MOZVERS
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Fix a long standing bug that's prevented staying current on GTK+.
-# Thanks to the BLFS folks. :-)
-cat << EOF >> layout/build/Makefile.in
-
-ifdef MOZ_ENABLE_CANVAS
-EXTRA_DSO_LDOPTS += \$(XLDFLAGS) -lX11 -lXrender
-endif
-
-EOF
-
-# Our building options, in a configure-like display
-OPTIONS="\
- --enable-official-branding \
- --prefix=/usr \
- --libdir=/usr/lib$LIBDIRSUFFIX \
- --with-default-mozilla-five-home=/usr/lib$LIBDIRSUFFIX/firefox-$RELEASEVER \
- --with-system-zlib \
- --enable-application=browser \
- --enable-default-toolkit=cairo-gtk2 \
- --enable-startup-notification \
- --enable-crypto \
- --enable-svg \
- --enable-canvas \
- --enable-logging \
- --enable-xft \
- --enable-webm \
- --enable-xinerama \
- --enable-optimize \
- --enable-reorder \
- --enable-strip \
- --enable-cpp-rtti \
- --enable-single-profile \
- --disable-gnomevfs \
- --disable-ldap \
- --disable-accessibility \
- --disable-crashreporter \
- --disable-debug \
- --disable-tests \
- --disable-pedantic \
- --disable-installer \
- --disable-mailnews \
- --disable-composer \
- --disable-profilesharing"
-# Complains about missing APNG support in Slackware's libpng:
-# --with-system-png \
-# This option breaks mozilla-12.0:
-# --enable-system-cairo \
-
-# Mozilla devs enforce using an objdir for building
-# and launching configure with the absolute path
-# https://developer.mozilla.org/en/Configuring_Build_Options#Building_with_an_objdir
-mkdir obj
-export MOZILLA_OFFICIAL="1"
-export BUILD_OFFICIAL="1"
-export MOZ_PHOENIX="1"
-export CFLAGS="$SLKCFLAGS"
-export CXXFLAGS="$SLKCFLAGS"
-export MOZ_MAKE_FLAGS="$MAKEFLAGS"
-unset DBUS_SESSION_BUS_ADDRESS ORBIT_SOCKETDIR SESSION_MANAGER \
- XDG_SESSION_COOKIE XAUTHORITY MAKEFLAGS
-
-# Assemble our .mozconfig, we use this method for building, seems
-# needed for PGO.
-echo ". \$topsrcdir/browser/config/mozconfig" > .mozconfig
-echo "mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj" >> .mozconfig
-for option in $OPTIONS; do echo "ac_add_options $option" >> .mozconfig; done
-
-# Thanks to ArchLinux and Gentoo for the hints.
-# We use Xvfb to let the build run his profile tests.
-if [ "$PGO" = "yes" ]; then
- echo "mk_add_options PROFILE_GEN_SCRIPT='\$(PYTHON) \$(MOZ_OBJDIR)/_profile/pgo/profileserver.py 10'" >> .mozconfig
- export MOZ_PGO=1
- export DISPLAY=:99
- Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY &
- dbus-launch --exit-with-session make -f client.mk build
- kill $! || true
- make -f client.mk install DESTDIR=$PKG
-else
- make -f client.mk build
- make -f client.mk install DESTDIR=$PKG
-fi
-
-# We don't need these (just symlinks anyway):
-rm -rf $PKG/usr/lib$LIBDIRSUFFIX/firefox-devel-$RELEASEVER
-
-# Nor these:
-rm -rf $PKG/usr/include
-
-mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/mozilla/plugins
-mkdir -p $PKG/usr/share/applications
-cat $CWD/mozilla-firefox.desktop > $PKG/usr/share/applications/mozilla-firefox.desktop
-
-# These files/directories are usually created if Firefox is run as root,
-# which on many systems might (and possibly should) be never. Therefore, if we
-# don't see them we'll put stubs in place to prevent startup errors.
-( cd $PKG/usr/lib$LIBDIRSUFFIX/firefox-$RELEASEVER
- if [ -d extensions/talkback\@mozilla.org ]; then
- if [ ! -r extensions/talkback\@mozilla.org/chrome.manifest ]; then
- echo > extensions/talkback\@mozilla.org/chrome.manifest
- fi
- fi
- if [ ! -d updates ]; then
- mkdir -p updates/0
- fi
-)
-
-# Need some default icons in the right place:
-for i in 16 22 24 32 48 256; do
- install -m 0644 -D browser/branding/official/default${i}.png \
- $PKG/usr/share/icons/hicolor/${i}x${i}/apps/firefox.png
-done
-mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/firefox-$RELEASEVER/chrome/icons/default
-install -m 644 browser/branding/official/default16.png \
- $PKG/usr/lib$LIBDIRSUFFIX/firefox-$RELEASEVER/icons/
-install -m 644 browser/branding/official/default16.png \
- $PKG/usr/lib$LIBDIRSUFFIX/firefox-$RELEASEVER/chrome/icons/default/
-
-# Copy over the LICENSE
-install -p -c -m 644 LICENSE $PKG/usr/lib$LIBDIRSUFFIX/firefox-$RELEASEVER/
-
-mkdir $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}