summaryrefslogtreecommitdiff
path: root/network/dwb/dwb.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/dwb/dwb.SlackBuild')
-rw-r--r--network/dwb/dwb.SlackBuild42
1 files changed, 32 insertions, 10 deletions
diff --git a/network/dwb/dwb.SlackBuild b/network/dwb/dwb.SlackBuild
index c60ae28851..fc108f8da9 100644
--- a/network/dwb/dwb.SlackBuild
+++ b/network/dwb/dwb.SlackBuild
@@ -1,9 +1,32 @@
#!/bin/sh
-# Slackware build script for dwb by Marcin Herda <mherda@slackword.net>
+# Slackware build script for dwb
+# Originally by Marcin Herda <mherda@slackword.net>
+
+# Ryan P.C. McQuen | Everett, WA | ryan.q@linux.com
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version, with the following exception:
+# the text of the GPL license may be omitted.
+
+# This program is distributed in the hope that it will be useful, but
+# without any warranty; without even the implied warranty of
+# merchantability or fitness for a particular purpose. Compiling,
+# interpreting, executing or merely reading the text of the program
+# may result in lapses of consciousness and/or very being, up to and
+# including the end of all existence and the Universe as we know it.
+# See the GNU General Public License for more details.
+
+# You may have received a copy of the GNU General Public License along
+# with this program (most likely, a file named COPYING). If not, see
+# <https://www.gnu.org/licenses/>.
PRGNAM=dwb
-VERSION=${VERSION:-20150419_8ba11e5}
+VERSION=${VERSION:-20150726_dda5aa7}
+SRCVERSION=${SRCVERSION:-dda5aa74a63a}
+SRCNAM=${SRCNAM:-portix-dwb}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -39,20 +62,19 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$SRCVERSION
+tar xvf $CWD/$SRCVERSION.tar.bz2 || tar xvf $CWD/$SRCNAM-$SRCVERSION.tar.bz2
+cd $SRCNAM-$SRCVERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# fix the location of man pages
sed -i '/^MANDIR/s/DATAROOTDIR/PREFIX/' config.mk
-
CFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG