summaryrefslogtreecommitdiff
path: root/misc/conkyforecast/conkyforecast.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'misc/conkyforecast/conkyforecast.SlackBuild')
-rw-r--r--misc/conkyforecast/conkyforecast.SlackBuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/misc/conkyforecast/conkyforecast.SlackBuild b/misc/conkyforecast/conkyforecast.SlackBuild
index d966ac1de9..118e176111 100644
--- a/misc/conkyforecast/conkyforecast.SlackBuild
+++ b/misc/conkyforecast/conkyforecast.SlackBuild
@@ -5,7 +5,7 @@
# Written by M.Dinslage (daedra1980@gmail.com)
PRGNAM=conkyforecast
-VERSION=${VERSION:-2.15}
+VERSION=${VERSION:-2.12}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -21,9 +21,10 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf src
-tar xvf $CWD/${PRGNAM}_${VERSION}.tar.gz
-cd src
+rm -rf $PRGNAM-$VERSION
+mkdir -p $PRGNAM-$VERSION
+tar xvf $CWD/${PRGNAM}_${VERSION}.tar.gz -C $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION/src
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -39,6 +40,13 @@ python setup.py install --root=$PKG
# remove font .sfd files, they shouldn't be needed
rm -r $PKG/usr/share/fonts/TTF/*.tar.gz
+# Put the .otf fonts in the right place
+mkdir -p $PKG/usr/share/fonts/OTF
+mv $PKG/usr/share/fonts/TTF/*.otf $PKG/usr/share/fonts/OTF
+
+# No need to put an arch-specific dir in here; the egg info file is useless
+rm -rf $PKG/usr/lib{,64}
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS CHANGELOG COPYING README \