summaryrefslogtreecommitdiff
path: root/libraries/python-levenshtein/python-levenshtein.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/python-levenshtein/python-levenshtein.SlackBuild')
-rw-r--r--libraries/python-levenshtein/python-levenshtein.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/libraries/python-levenshtein/python-levenshtein.SlackBuild b/libraries/python-levenshtein/python-levenshtein.SlackBuild
index cc4bd9ac9a..5e3cb946a4 100644
--- a/libraries/python-levenshtein/python-levenshtein.SlackBuild
+++ b/libraries/python-levenshtein/python-levenshtein.SlackBuild
@@ -55,14 +55,15 @@ chmod -R u+w,go+r-w,a-s .
CFLAGS="$SLKCFLAGS" \
python setup.py bdist
-tar -C $PKG -zxvf dist/$DISTNAM-$VERSION.linux-i686.tar.gz
+tar zxvf dist/$DISTNAM-$VERSION.linux-i686.tar.gz -C $PKG
-find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+( find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : \
+ | xargs strip --strip-unneeded 2> /dev/null )
# Generate HTML documentation that describes the module functions.
# Maybe we'll want to replace the Python version number with a variable
# in the future, but for the moment this is for Slackware Linux 11.
-PYTHONPATH=$PKG/usr/lib/python2.4/site-packages sh gendoc.sh --selfcontained
+PYTHONPATH=$PKG/usr/lib/python2.5/site-packages sh gendoc.sh --selfcontained
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING Levenshtein.html NEWS README $PKG/usr/doc/$PRGNAM-$VERSION