summaryrefslogtreecommitdiff
path: root/libraries/Mako/Mako.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/Mako/Mako.SlackBuild')
-rw-r--r--libraries/Mako/Mako.SlackBuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/libraries/Mako/Mako.SlackBuild b/libraries/Mako/Mako.SlackBuild
index f06e7fe0eb..4bc039d13e 100644
--- a/libraries/Mako/Mako.SlackBuild
+++ b/libraries/Mako/Mako.SlackBuild
@@ -5,7 +5,7 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=Mako
-VERSION=${VERSION:-0.2.5}
+VERSION=0.3.2
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -32,12 +32,11 @@ find . \
python setup.py install --root=$PKG
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
-)
+# Remove *.pyc files
+find $PKG -name "*.pyc" -exec rm -f {} \;
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \