summaryrefslogtreecommitdiff
path: root/graphics/paraview/1201.diff
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/paraview/1201.diff')
-rw-r--r--graphics/paraview/1201.diff35
1 files changed, 35 insertions, 0 deletions
diff --git a/graphics/paraview/1201.diff b/graphics/paraview/1201.diff
new file mode 100644
index 0000000000..04b5345de6
--- /dev/null
+++ b/graphics/paraview/1201.diff
@@ -0,0 +1,35 @@
+# Upstream patch to fix building of PythonQt plugin.
+# From http://gitlab.kitware.com/paraview/paraview/merge_requests/1201/diffs
+#
+diff --git a/Plugins/PythonQtPlugin/CMakeLists.txt b/Plugins/PythonQtPlugin/CMakeLists.txt
+index d87853b..d249961 100644
+--- a/Plugins/PythonQtPlugin/CMakeLists.txt
++++ b/Plugins/PythonQtPlugin/CMakeLists.txt
+@@ -7,6 +7,8 @@ else()
+ include(${PARAVIEW_USE_FILE})
+ endif()
+
++include(ParaViewQt)
++pv_find_package_qt(qt_targets REQUIRED QT4_COMPONENTS QtGui QT5_COMPONENTS Widgets)
+
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR})
+ find_package(PythonQt REQUIRED)
+@@ -23,17 +25,7 @@ set(PythonQtPlugin_MOC_SRCS
+ pqPythonEventFilter.h
+ )
+
+-if (PARAVIEW_QT_VERSION VERSION_GREATER "4")
+- qt5_wrap_cpp(MOC_SRCS
+- ${PythonQtPlugin_MOC_SRCS}
+- ${decorator_file}
+- )
+-else ()
+- qt4_wrap_cpp(MOC_SRCS
+- ${PythonQtPlugin_MOC_SRCS}
+- ${decorator_file}
+- )
+-endif ()
++pv_qt_wrap_cpp(MOC_SRCS ${PythonQtPlugin_MOC_SRCS} ${decorator_file})
+
+ set(srcs
+ pqPythonQtPlugin.cxx