summaryrefslogtreecommitdiff
path: root/games/yabause/yabause.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/yabause/yabause.SlackBuild')
-rw-r--r--games/yabause/yabause.SlackBuild31
1 files changed, 25 insertions, 6 deletions
diff --git a/games/yabause/yabause.SlackBuild b/games/yabause/yabause.SlackBuild
index 5ee718adac..90c7637092 100644
--- a/games/yabause/yabause.SlackBuild
+++ b/games/yabause/yabause.SlackBuild
@@ -2,10 +2,28 @@
# Slackware build script for yabause
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2011-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=yabause
-VERSION=${VERSION:-0.9.11}
+VERSION=${VERSION:-0.9.12}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -54,13 +72,14 @@ find . \
# Variable to determine gtk/qt interface. Default is qt.
USE_GUI=${USE_GUI:-qt}
-# Fix location of man file and use SLKCFLAGS.
-sed -i 's|share/man|man|' src/${USE_GUI}/CMakeLists.txt
-sed -i "s|-O3|$SLKCFLAGS|" src/CMakeLists.txt
+# Fix location of man file.
+sed -i 's|share/man|man|' src/CMakeLists.txt
+# Fix hard linked lib directory for gtkglext detection.
+sed -i "s|lib/|lib${LIBDIRSUFFIX}/|" src/gtk/CMakeLists.txt
mkdir build
cd build
- cmake "Unix Makefiles" \
+ cmake -G "Unix Makefiles" \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \