summaryrefslogtreecommitdiff
path: root/games/yabause/yabause.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/yabause/yabause.SlackBuild')
-rw-r--r--games/yabause/yabause.SlackBuild37
1 files changed, 24 insertions, 13 deletions
diff --git a/games/yabause/yabause.SlackBuild b/games/yabause/yabause.SlackBuild
index 84f136db31..b3706d90fd 100644
--- a/games/yabause/yabause.SlackBuild
+++ b/games/yabause/yabause.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for yabause
-# Copyright 2011-2015 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2011-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=yabause
-VERSION=${VERSION:-0.9.14}
+VERSION=${VERSION:-0.9.15}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -64,16 +64,23 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Variable to determine gtk/qt interface. Default is qt.
USE_GUI=${USE_GUI:-qt}
# Fix location of man file.
sed -i 's|share/man|man|' src/CMakeLists.txt
+# Fix png files.
+# Eg.: ibpng warning: iCCP: known incorrect sRGB profile
+for pic in $(find . -name "*\.png");do
+ convert $pic ${pic}.new
+ touch -r $pic ${pic}.new
+ mv ${pic}.new $pic
+done
mkdir build
cd build
@@ -81,16 +88,22 @@ cd build
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DYAB_USE_CXX:BOOL=ON \
+ -DYAB_WANT_MPEG:BOOL=ON \
+ -DYAB_USE_SSF:BOOL=ON \
+ -DYAB_USE_SCSP2:BOOL=OFF \
+ -DYAB_USE_SCSPMIDI:BOOL=ON \
+ -DYAB_MAN_DIR:PATH="man" \
-DYAB_PORTS="$USE_GUI" \
- -DYAB_MULTIBUILD=OFF \
- -DYAB_NETWORK=ON \
- -DYAB_OPTIMIZED_DMA=ON \
+ -DYAB_MULTIBUILD:BOOL=OFF \
+ -DYAB_NETWORK:BOOL=ON \
+ -DYAB_OPTIMIZED_DMA:BOOL=ON \
-DGDKGLEXT_CONFIG_INCLUDE_DIR:PATH="/usr/lib${LIBDIRSUFFIX}/gtkglext-1.0/include" \
-DCMAKE_BUILD_TYPE=Release ..
make VERBOSE=1
make install DESTDIR=$PKG
-cd ..
+cd -
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -98,9 +111,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS ChangeLog COPYING GOALS INSTALL README{,.LIN,.QT} TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS ChangeLog COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install