summaryrefslogtreecommitdiff
path: root/games/xmoto/patches
diff options
context:
space:
mode:
Diffstat (limited to 'games/xmoto/patches')
-rw-r--r--games/xmoto/patches/localedir.diff12
-rw-r--r--games/xmoto/patches/sqlite3.diff30
-rw-r--r--games/xmoto/patches/xmoto-amd64_gcc441.diff35
3 files changed, 0 insertions, 77 deletions
diff --git a/games/xmoto/patches/localedir.diff b/games/xmoto/patches/localedir.diff
deleted file mode 100644
index 238e1de4a5..0000000000
--- a/games/xmoto/patches/localedir.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur xmoto-0.5.0.orig/po/Makefile.in.in xmoto-0.5.0/po/Makefile.in.in
---- xmoto-0.5.0.orig/po/Makefile.in.in 2008-11-23 09:32:28.000000000 +0000
-+++ xmoto-0.5.0/po/Makefile.in.in 2009-03-30 20:44:01.000000000 +0000
-@@ -26,7 +26,7 @@
- datarootdir = @datarootdir@
- datadir = @datadir@
- localedir = @localedir@
--gettextsrcdir = $(datadir)/gettext/po
-+gettextsrcdir = @localedir@/gettext/po
-
- INSTALL = @INSTALL@
- INSTALL_DATA = @INSTALL_DATA@
diff --git a/games/xmoto/patches/sqlite3.diff b/games/xmoto/patches/sqlite3.diff
deleted file mode 100644
index 8d47a140f7..0000000000
--- a/games/xmoto/patches/sqlite3.diff
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -Naur xmoto-0.5.0.orig/configure xmoto-0.5.0/configure
---- xmoto-0.5.0.orig/configure 2008-11-23 09:33:21.000000000 +0000
-+++ xmoto-0.5.0/configure 2009-03-30 20:52:48.000000000 +0000
-@@ -5104,7 +5104,7 @@
- cat >>confdefs.h <<_ACEOF
- #define `echo "HAVE_$ac_header" | $as_tr_cpp` 1
- _ACEOF
-- SQLITE_LIBS=-lsqlite3
-+ SQLITE_LIBS=`pkg-config --static --libs sqlite3`
- else
- { { echo "$as_me:$LINENO: error: \"sqlite3 required\"" >&5
- echo "$as_me: error: \"sqlite3 required\"" >&2;}
-@@ -5120,7 +5120,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lsqlite3 $LIBS"
-+LIBS="`pkg-config --static --libs sqlite3` $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -5174,7 +5174,7 @@
- #define HAVE_LIBSQLITE3 1
- _ACEOF
-
-- LIBS="-lsqlite3 $LIBS"
-+ LIBS="`pkg-config --static --libs sqlite3` $LIBS"
-
- else
- { { echo "$as_me:$LINENO: error: \"Linking against sqlite3 failed.\"" >&5
diff --git a/games/xmoto/patches/xmoto-amd64_gcc441.diff b/games/xmoto/patches/xmoto-amd64_gcc441.diff
deleted file mode 100644
index bc0f47e693..0000000000
--- a/games/xmoto/patches/xmoto-amd64_gcc441.diff
+++ /dev/null
@@ -1,35 +0,0 @@
-http://bugs.gentoo.org/284464
-
---- src/DBuffer.h.org 2009-09-10 11:58:28.000000000 +0200
-+++ src/DBuffer.h 2009-09-10 12:07:30.000000000 +0200
-@@ -69,6 +69,8 @@
- void operator >>(unsigned char &c);
- void operator <<(unsigned int n);
- void operator >>(unsigned int &n);
-+ void operator <<(unsigned long n);
-+ void operator >>(unsigned long &n);
- void operator <<(float n);
- void operator >>(float &n);
- void operator <<(std::string s);
-
---- src/DBuffer.cpp.org 2009-09-10 11:58:38.000000000 +0200
-+++ src/DBuffer.cpp 2009-09-10 12:08:18.000000000 +0200
-@@ -210,6 +210,18 @@
- n = (unsigned int) sn;
- }
-
-+ void DBuffer::operator <<(unsigned long n) {
-+ int sn;
-+ sn = (int) (n);
-+ *this << sn;
-+ }
-+
-+ void DBuffer::operator >>(unsigned long &n) {
-+ int sn;
-+ *this >> sn;
-+ n = (unsigned long) sn;
-+ }
-+
- void DBuffer::operator <<(float n) {
- writeBuf_LE((char *)&n, sizeof(float));
- }