summaryrefslogtreecommitdiff
path: root/games/jfsw/patches/sdl1_fix.diff
diff options
context:
space:
mode:
Diffstat (limited to 'games/jfsw/patches/sdl1_fix.diff')
-rw-r--r--games/jfsw/patches/sdl1_fix.diff12
1 files changed, 12 insertions, 0 deletions
diff --git a/games/jfsw/patches/sdl1_fix.diff b/games/jfsw/patches/sdl1_fix.diff
new file mode 100644
index 0000000000..1e68caab33
--- /dev/null
+++ b/games/jfsw/patches/sdl1_fix.diff
@@ -0,0 +1,12 @@
+diff -Naur jfsw.orig/jfaudiolib/Makefile.shared jfsw/jfaudiolib/Makefile.shared
+--- jfsw.orig/jfaudiolib/Makefile.shared 2017-02-02 07:22:54.000000000 -0500
++++ jfsw/jfaudiolib/Makefile.shared 2018-07-12 15:31:55.593300348 -0400
+@@ -22,7 +22,7 @@
+ else
+ ifeq (yes,$(shell pkg-config --exists sdl && echo yes))
+ JFAUDIOLIB_HAVE_SDL=1
+- JFAUDIOLIB_LDFLAGS+= $(shell pkg-config --libs sdl1)
++ JFAUDIOLIB_LDFLAGS+= $(shell pkg-config --libs sdl)
+ endif
+ endif
+ ifeq (yes,$(shell pkg-config --exists alsa && echo yes))