summaryrefslogtreecommitdiff
path: root/development/pysetuptools/pysetuptools.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/pysetuptools/pysetuptools.SlackBuild')
-rw-r--r--development/pysetuptools/pysetuptools.SlackBuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/development/pysetuptools/pysetuptools.SlackBuild b/development/pysetuptools/pysetuptools.SlackBuild
index d08da37ef9..171e2b875b 100644
--- a/development/pysetuptools/pysetuptools.SlackBuild
+++ b/development/pysetuptools/pysetuptools.SlackBuild
@@ -7,20 +7,15 @@
## so that I don't recieve emails about a script I
## did not write. Thanks.
-# Modified by the SlackBuilds.org project
-
-if [ "$(id -u)" != "0" ]; then
- echo "This script must be run as root!"
- exit
-fi
+# Mofified by the SlackBuilds.org project
NAME=setuptools
PKG_NAME=pysetuptools
-VERSION=0.6c3
+VERSION=0.6c6
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-CWD=`pwd`
+CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=${PKG:-$TMP/package-$NAME}
OUTPUT=${OUTPUT:-/tmp}
@@ -35,14 +30,15 @@ chown -R root:root .
chmod -R u+w,go+r-w,a-s .
python setup.py bdist || exit 1
+tar zxvf dist/$NAME-$VERSION.linux-i686.tar.gz -C $PKG || exit 1
-tar -C $PKG -zxvf dist/$NAME-$VERSION.linux-i686.tar.gz || exit 1
-
-find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
mkdir -p $PKG/usr/doc/$PKG_NAME-$VERSION
-cp -a PKG_INFO $PKG/usr/doc/$PKG_NAME-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PKG_NAME-$VERSION
install -m 0644 *.txt $PKG/usr/doc/$PKG_NAME-$VERSION
cat $CWD/$PKG_NAME.SlackBuild > $PKG/usr/doc/$PKG_NAME-$VERSION/$PKG_NAME.SlackBuild