summaryrefslogtreecommitdiff
path: root/development/pycrypto/pycrypto.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/pycrypto/pycrypto.SlackBuild')
-rw-r--r--development/pycrypto/pycrypto.SlackBuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/development/pycrypto/pycrypto.SlackBuild b/development/pycrypto/pycrypto.SlackBuild
index daf103df8e..a94ef1f89e 100644
--- a/development/pycrypto/pycrypto.SlackBuild
+++ b/development/pycrypto/pycrypto.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pycrypto
-# Copyright 2008 Heinz Wiesinger <pprkut@liwjatan.at>
+# Copyright 2008-2009 Heinz Wiesinger <pprkut@liwjatan.at>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
PRGNAM=pycrypto
VERSION=2.0.1
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
CWD=$(pwd)
@@ -56,6 +56,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Fixes buffer overflow in the PyCrypto ARC2 module
+patch -p1 -i $CWD/pycrypto-CVE-2009-0544.patch
+
python setup.py install --root=$PKG
find $PKG | xargs file | grep "shared object" | grep ELF | \