summaryrefslogtreecommitdiff
path: root/development/numexpr/numexpr.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/numexpr/numexpr.SlackBuild')
-rw-r--r--development/numexpr/numexpr.SlackBuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/development/numexpr/numexpr.SlackBuild b/development/numexpr/numexpr.SlackBuild
index ca9b95d968..669af87309 100644
--- a/development/numexpr/numexpr.SlackBuild
+++ b/development/numexpr/numexpr.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=numexpr
-VERSION=${VERSION:-1.4.2}
+VERSION=${VERSION:-2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -68,15 +68,18 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
-CFLAGS=$SLKCFLAGS python setup.py build install --root=$PKG
+python setup.py build install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# Move documentation .pdf files and text files to avoid file duplication in
-# python directory
+# Move documentation .pdf files and text files to avoid file duplication
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
mv $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild