summaryrefslogtreecommitdiff
path: root/desktop/slock/config.mk.patch
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/slock/config.mk.patch')
-rw-r--r--desktop/slock/config.mk.patch21
1 files changed, 4 insertions, 17 deletions
diff --git a/desktop/slock/config.mk.patch b/desktop/slock/config.mk.patch
index 7c659ee51d..b6eba0aee0 100644
--- a/desktop/slock/config.mk.patch
+++ b/desktop/slock/config.mk.patch
@@ -1,25 +1,12 @@
---- a/config.mk 2009-01-01 02:25:45.983700591 -0600
-+++ b/config.mk 2009-01-01 02:27:16.479701293 -0600
-@@ -4,10 +4,10 @@
- # Customize below to fit your system
-
- # paths
--PREFIX = /usr/local
-+PREFIX = /usr
-
--X11INC = /usr/X11R6/include
--X11LIB = /usr/X11R6/lib
-+X11INC = /usr/include/X11
-+X11LIB = /usr/lib/X11
-
- # includes and libs
- INCS = -I. -I/usr/include -I${X11INC}
+diff -Nur slock-0.9.orig/config.mk slock-0.9/config.mk
+--- slock-0.9.orig/config.mk 2008-07-29 13:22:46.000000000 -0500
++++ slock-0.9/config.mk 2009-07-06 00:50:51.209930578 -0500
@@ -15,7 +15,7 @@
# flags
CPPFLAGS = -DVERSION=\"${VERSION}\" -DHAVE_SHADOW_H
-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
-+CFLAGS = _SLACKCFLAGS_ -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
++CFLAGS = @SLACKCFLAGS@ -std=c99 -pedantic -Wall ${INCS} ${CPPFLAGS}
LDFLAGS = -s ${LIBS}
# On *BSD remove -DHAVE_SHADOW_H from CPPFLAGS and add -DHAVE_BSD_AUTH