summaryrefslogtreecommitdiff
path: root/desktop/bar/patches/bar-Makefile-CFLAGS.patch
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/bar/patches/bar-Makefile-CFLAGS.patch')
-rw-r--r--desktop/bar/patches/bar-Makefile-CFLAGS.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/desktop/bar/patches/bar-Makefile-CFLAGS.patch b/desktop/bar/patches/bar-Makefile-CFLAGS.patch
new file mode 100644
index 0000000000..bef2cba8ff
--- /dev/null
+++ b/desktop/bar/patches/bar-Makefile-CFLAGS.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index ff620a8..01b6bf9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,7 @@
+ CC ?= gcc
+ STRIP ?= strip
+-CFLAGS = -std=c99 -Os
++CFLAGS ?= -Os
++CFLAGS += -std=c99
+ LDFLAGS = -lxcb -lxcb-xinerama -lxcb-randr
+ CFDEBUG = -g3 -pedantic -Wall -Wunused-parameter -Wlong-long\
+ -Wsign-conversion -Wconversion -Wimplicit-function-declaration