summaryrefslogtreecommitdiff
path: root/audio/jokosher/jokosher.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'audio/jokosher/jokosher.SlackBuild')
-rw-r--r--audio/jokosher/jokosher.SlackBuild20
1 files changed, 16 insertions, 4 deletions
diff --git a/audio/jokosher/jokosher.SlackBuild b/audio/jokosher/jokosher.SlackBuild
index 9500eb109f..5f36e9192d 100644
--- a/audio/jokosher/jokosher.SlackBuild
+++ b/audio/jokosher/jokosher.SlackBuild
@@ -2,8 +2,11 @@
# Slackware build script for jokosher
+# Formerly maintained by:
# Ryan P.C. McQuen | Everett, WA | ryanpcmcquen@member.fsf.org
+# Now maintained by B. Watson (yalhcru@gmail.com)
+
# Copyright 2010 Binh Nguyen <binhvng@gmail.com>
# All rights reserved.
#
@@ -24,6 +27,11 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20170310 bkw:
+# - take over maintenanace
+# - i486 => i586
+# - stop spamming /usr
+
PRGNAM=jokosher
VERSION=${VERSION:-0.11.5}
BUILD=${BUILD:-1}
@@ -31,7 +39,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -57,14 +65,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# 20170310 bkw: Don't let setup.py spam /usr by running
+# update-mime-database and update-desktop-database. Be nice if
+# there were an option to setup.py to disable it, but there's not:
+sed -i 's,"update-[^"]*","true",' setup.py
+
python setup.py build
python setup.py install --skip-build --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# nothing to strip, no native code, only python.
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING* PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install