summaryrefslogtreecommitdiff
path: root/academic/spqr/autotoolize.diff
diff options
context:
space:
mode:
Diffstat (limited to 'academic/spqr/autotoolize.diff')
-rw-r--r--academic/spqr/autotoolize.diff20
1 files changed, 13 insertions, 7 deletions
diff --git a/academic/spqr/autotoolize.diff b/academic/spqr/autotoolize.diff
index 3b4efd6f02..f11f72434a 100644
--- a/academic/spqr/autotoolize.diff
+++ b/academic/spqr/autotoolize.diff
@@ -2,13 +2,12 @@ diff --git a/Demo/Makefile.am b/Demo/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Demo/Makefile.am
-@@ -0,0 +1,109 @@
+@@ -0,0 +1,111 @@
+AM_CPPFLAGS = -I$(top_srcdir)/Include $(CHOLMOD_CFLAGS) $(SUITESPARSECONFIG_CFLAGS)
+LDADD = $(top_builddir)/Source/libspqr.la
+
+EXTRA_DIST = \
+ README.txt \
-+ qrdemo_diary.txt \
+ qrdemo_out.txt \
+ qrdemoc_out.txt
+
@@ -51,7 +50,8 @@ new file mode 100644
+ $(top_srcdir)/Matrix/r2.mtx \
+ $(top_srcdir)/Matrix/s32.mtx \
+ $(top_srcdir)/Matrix/west0067.mtx \
-+ $(top_srcdir)/Matrix/young1c.mtx
++ $(top_srcdir)/Matrix/young1c.mtx \
++ $(top_srcdir)/Matrix/lp_e226_transposed.mtx
+
+check-local: $(check_PROGRAMS) $(MATRICES)
+ -./qrsimple < $(top_srcdir)/Matrix/ash219.mtx
@@ -85,6 +85,7 @@ new file mode 100644
+ -./qrdemo < $(top_srcdir)/Matrix/GD98_a.mtx
+ -./qrdemo < $(top_srcdir)/Matrix/Ragusa16.mtx
+ -./qrdemo < $(top_srcdir)/Matrix/young1c.mtx
++ -./qrdemo < $(top_srcdir)/Matrix/lp_e226_transposed.mtx
+ -./qrdemoc < $(top_srcdir)/Matrix/a2.mtx
+ -./qrdemoc < $(top_srcdir)/Matrix/r2.mtx
+ -./qrdemoc < $(top_srcdir)/Matrix/a04.mtx
@@ -112,6 +113,7 @@ new file mode 100644
+ -./qrdemoc < $(top_srcdir)/Matrix/GD98_a.mtx
+ -./qrdemoc < $(top_srcdir)/Matrix/Ragusa16.mtx
+ -./qrdemoc < $(top_srcdir)/Matrix/young1c.mtx
++ -./qrdemoc < $(top_srcdir)/Matrix/lp_e226_transposed.mtx
diff --git a/Doc/Makefile.am b/Doc/Makefile.am
new file mode 100644
--- /dev/null
@@ -169,7 +171,7 @@ diff --git a/Matrix/Makefile.am b/Matrix/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Matrix/Makefile.am
-@@ -0,0 +1,32 @@
+@@ -0,0 +1,36 @@
+EXTRA_DIST = \
+ README.txt
+
@@ -201,7 +203,11 @@ new file mode 100644
+ r2.mtx \
+ s32.mtx \
+ west0067.mtx \
-+ young1c.mtx
++ young1c.mtx \
++ Franz6_id1959_aug.mtx \
++ Groebner_id2003_aug.mtx \
++ lp_e226.mtx \
++ lp_e226_transposed.mtx
diff --git a/Source/Makefile.am b/Source/Makefile.am
new file mode 100644
--- /dev/null
@@ -260,7 +266,7 @@ new file mode 100644
+ spqr_type.cpp
+
+libspqr_la_LIBADD = $(TBB_LIBS) $(CHOLMOD_LIBS) $(SUITESPARSECONFIG_LIBS) $(LAPACK_LIBS) $(BLAS_LIBS) -lm
-+libspqr_la_LDFLAGS = -no-undefined -version-number 1:3:1
++libspqr_la_LDFLAGS = -no-undefined -release $(PACKAGE_VERSION)
diff --git a/ax_blas.m4 b/ax_blas.m4
new file mode 100644
--- /dev/null
@@ -649,7 +655,7 @@ new file mode 100644
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
-+AC_INIT([SPQR],[1.3.1],[DrTimothyAldenDavis@gmail.com],[spqr],[http://www.suitesparse.com/])
++AC_INIT([SPQR],[2.0.1],[DrTimothyAldenDavis@gmail.com],[spqr],[http://www.suitesparse.com/])
+AC_CONFIG_SRCDIR([Source/spqr_kernel.cpp])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign])