summaryrefslogtreecommitdiff
path: root/academic/grace/patches/xmgrace-strip.patch
diff options
context:
space:
mode:
Diffstat (limited to 'academic/grace/patches/xmgrace-strip.patch')
-rw-r--r--academic/grace/patches/xmgrace-strip.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/academic/grace/patches/xmgrace-strip.patch b/academic/grace/patches/xmgrace-strip.patch
new file mode 100644
index 0000000000..5ac62995cc
--- /dev/null
+++ b/academic/grace/patches/xmgrace-strip.patch
@@ -0,0 +1,33 @@
+--- auxiliary/Makefile
++++ auxiliary/Makefile
+@@ -27,7 +27,7 @@
+ install : $(AUXILIARIES) $(PROGRAMS) $(SCRIPTS)
+ $(MKINSTALLDIRS) $(DESTDIR)$(GRACE_HOME)/auxiliary
+ for i in $(AUXILIARIES); do $(INSTALL_DATA) $$i $(DESTDIR)$(GRACE_HOME)/auxiliary; done
+- for i in $(PROGRAMS); do $(INSTALL_PROGRAM) -s $$i $(DESTDIR)$(GRACE_HOME)/bin; done
++ for i in $(PROGRAMS); do $(INSTALL_PROGRAM) $$i $(DESTDIR)$(GRACE_HOME)/bin; done
+ for i in $(SCRIPTS); do $(INSTALL_PROGRAM) $$i $(DESTDIR)$(GRACE_HOME)/bin; done
+
+ tests : dummy
+--- grconvert/Makefile
++++ grconvert/Makefile
+@@ -42,7 +42,7 @@
+
+ install : $(PROG)
+ $(MKINSTALLDIRS) $(DESTDIR)$(GRACE_HOME)/bin
+- $(INSTALL_PROGRAM) -s $(PROG) $(DESTDIR)$(GRACE_HOME)/bin/$(PROG)
++ $(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(GRACE_HOME)/bin/$(PROG)
+
+ dummy :
+
+--- src/Makefile
++++ src/Makefile
+@@ -60,7 +60,7 @@
+
+ install : $(GRACE)
+ $(MKINSTALLDIRS) $(DESTDIR)$(GRACE_HOME)/bin
+- $(INSTALL_PROGRAM) -s $(GRACE) $(DESTDIR)$(GRACE_HOME)/bin/$(GRACE)
++ $(INSTALL_PROGRAM) $(GRACE) $(DESTDIR)$(GRACE_HOME)/bin/$(GRACE)
+ cd $(DESTDIR)$(GRACE_HOME)/bin; $(RM) $(GRBATCH); $(LN_S) $(GRACE) $(GRBATCH)
+
+ tests : dummy