summaryrefslogtreecommitdiff
path: root/academic/biopython/biopython.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/biopython/biopython.SlackBuild')
-rw-r--r--academic/biopython/biopython.SlackBuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/academic/biopython/biopython.SlackBuild b/academic/biopython/biopython.SlackBuild
index 22bd291d1f..70fdc87663 100644
--- a/academic/biopython/biopython.SlackBuild
+++ b/academic/biopython/biopython.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for biopython
-# Copyright 2019 Petar Petrov slackalaxy@gmail.com
+# Copyright 2019-2021 Petar Petrov slackalaxy@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=biopython
-VERSION=${VERSION:-1.74}
+VERSION=${VERSION:-1.78}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,7 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true