summaryrefslogtreecommitdiff
path: root/academic/Kst/Kst.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/Kst/Kst.SlackBuild')
-rw-r--r--academic/Kst/Kst.SlackBuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/academic/Kst/Kst.SlackBuild b/academic/Kst/Kst.SlackBuild
index 0ab614f03d..527bc6ba1b 100644
--- a/academic/Kst/Kst.SlackBuild
+++ b/academic/Kst/Kst.SlackBuild
@@ -45,6 +45,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix build failure with gsl-2.1 (gsl API change)
+patch -p1 < $CWD/Kst_gsl2.patch
+
sed -i "s/find_package\(PythonLibs REQUIRED\)/SET \(PythonLibs \"\/usr\/lib${LIBDIRSUFFIX}\/libpython2.7.so\"\)/" \
./cmake/pyKst/CMakeLists.txt
sed -i "s/\${NUMPY_VERSION_PATCH}/0/" ./cmake/modules/FindNumPy.cmake