summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--python/google-apputils/google-apputils.SlackBuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/python/google-apputils/google-apputils.SlackBuild b/python/google-apputils/google-apputils.SlackBuild
index b808fa68e9..96fd672f4b 100644
--- a/python/google-apputils/google-apputils.SlackBuild
+++ b/python/google-apputils/google-apputils.SlackBuild
@@ -57,6 +57,10 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true