summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--development/squeak-vm/squeak-vm.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/development/squeak-vm/squeak-vm.SlackBuild b/development/squeak-vm/squeak-vm.SlackBuild
index 3f9b03f6c6..4d74200c10 100644
--- a/development/squeak-vm/squeak-vm.SlackBuild
+++ b/development/squeak-vm/squeak-vm.SlackBuild
@@ -64,11 +64,11 @@ rm -rf $SRCNAM-$VERSION-src
tar xvf $CWD/$SRCNAM-$VERSION-src.tar.gz
cd $SRCNAM-$VERSION-src
chown -R root:root .
-find . \
+find -L . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix location of libraries (as --libdir does not work)
for f in CMakeLists.txt cmake/squeak.in cmake/squeak.sh.in; do