summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorHeinz Wiesinger <pprkut@slackbuilds.org>2010-05-11 20:31:00 +0200
committerHeinz Wiesinger <pprkut@slackbuilds.org>2010-05-11 20:31:00 +0200
commitd0b0e987efe68b7a1fa8eb58f0bac1bfb56ca1f1 (patch)
tree0f6ee624b3f394b96ba43bc0e9705a173d1f18af /system
parent8f96493d16ced46c202b3190e1c128eb60820787 (diff)
downloadslackbuilds-d0b0e987efe68b7a1fa8eb58f0bac1bfb56ca1f1.tar.gz
system/aufs: Removed from 12.1 repository
Diffstat (limited to 'system')
-rw-r--r--system/aufs/README22
-rw-r--r--system/aufs/aufs.SlackBuild96
-rw-r--r--system/aufs/aufs.info8
-rw-r--r--system/aufs/doinst.sh1
-rw-r--r--system/aufs/slack-desc19
5 files changed, 0 insertions, 146 deletions
diff --git a/system/aufs/README b/system/aufs/README
deleted file mode 100644
index 89941a0e3e..0000000000
--- a/system/aufs/README
+++ /dev/null
@@ -1,22 +0,0 @@
-Aufs is a stackable unification filesystem such as Unionfs, which unifies
-several directories and provides a merged single directory.
-
-If you build on a multicore system, add JOBS={core #} to enable parallel
-compilation; for example, to start 4 build jobs simultaneously, do:
- JOBS=4 ./aufs.SlackBuild
-
-You can build this for a different kernel than the one which happens to be
-currently running - see the build script for details.
-
-Since there are no official aufs source tarballs, the download link refers
-to a tarball containing the CVS snapshot of version 20080128.
-After talking with the aufs developer, we learned that Monday's snapshots
-are considered "releases" of aufs. That being the case, you may certainly
-decide to use a later cvs snapshot than what we have tested, but there are
-no guarantees from us that it will compile cleanly or package properly.
-If changes in the upstream cvs repository necessitate changes to our build
-script, please let us know.
-
-Note: The download link for the source tarball points to the SlackBuilds.org
- server; this is because the upstream sources are only available via
- cvs.
diff --git a/system/aufs/aufs.SlackBuild b/system/aufs/aufs.SlackBuild
deleted file mode 100644
index 5259681af1..0000000000
--- a/system/aufs/aufs.SlackBuild
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for aufs
-
-# Copyright 2006-2008 Robby Workman Northport, AL
-# Copyright 2008 Mauro Giachero
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=aufs
-VERSION=${VERSION:-20080128}
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-${PRGNAM}
-OUTPUT=${OUTPUT:-/tmp}
-
-# To build for a different kernel than the one currently running,
-# pass the desired version as value to KERNEL on the command line
-# when running the build script. For example:
-# KERNEL=2.6.23.16-smp ./aufs.SlackBuild
-KERNEL=${KERNEL:-$(uname -r)}
-
-# Parallel compilation support
-JOBS=${JOBS:-1}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-fi
-
-set -e # Abort on most errors
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-
-cd $PRGNAM
-chown -R root:root .
-ARCH_KEEP=$ARCH ; unset ARCH # Causes name conflict with Linux makefiles
-EXTRA_CFLAGS=$SLKCFLAGS \
- make \
- -j${JOBS} \
- -f local.mk \
- KDIR=/lib/modules/$KERNEL/build
-ARCH=$ARCH_KEEP
-
-mkdir -p $PKG/sbin
-install -m 0500 -p mount.$PRGNAM umount.$PRGNAM auplink aulchown $PKG/sbin
-
-mkdir -p $PKG/lib/modules/$KERNEL/kernel/fs/$PRGNAM
-install -m 0644 -p $PRGNAM.ko $PKG/lib/modules/$KERNEL/kernel/fs/$PRGNAM
-
-mkdir -p $PKG/etc/default
-echo "FLUSH=ALL" > $PKG/etc/default/auplink
-
-mkdir -p $PKG/usr/man/man5
-cat $PRGNAM.5 | gzip -9c > $PKG/usr/man/man5/$PRGNAM.5.gz
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING History README sample $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION_$(echo $KERNEL |tr - _)-$ARCH-$BUILD$TAG.tgz
diff --git a/system/aufs/aufs.info b/system/aufs/aufs.info
deleted file mode 100644
index 51e27790f7..0000000000
--- a/system/aufs/aufs.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="aufs"
-VERSION="20080128"
-HOMEPAGE="http://aufs.sourceforge.net/"
-DOWNLOAD="http://slackbuilds.org/sources/12.0/aufs-20080128.tar.bz2"
-MD5SUM="02bd76e1e43132b9324d18ac398ca37b"
-MAINTAINER="Mauro Giachero"
-EMAIL="mauro.giachero@gmail.com"
-APPROVED="rworkman"
diff --git a/system/aufs/doinst.sh b/system/aufs/doinst.sh
deleted file mode 100644
index f660316712..0000000000
--- a/system/aufs/doinst.sh
+++ /dev/null
@@ -1 +0,0 @@
-chroot . /sbin/depmod -a
diff --git a/system/aufs/slack-desc b/system/aufs/slack-desc
deleted file mode 100644
index f6a6613ac5..0000000000
--- a/system/aufs/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-aufs: aufs - another unionfs
-aufs:
-aufs: Aufs is a stackable unification filesystem such as Unionfs, which
-aufs: unifies several directories and provides a merged single directory.
-aufs: In the early days, aufs was entirely re-designed and re-implemented
-aufs: Unionfs Version 1.x series. After many original ideas, approaches,
-aufs: and improvements, it becomes totally different from Unionfs while
-aufs: keeping the basic features. See Unionfs Version 1.x series for the
-aufs: basic features.
-aufs:
-aufs: