summaryrefslogtreecommitdiff
path: root/system
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackbuilds.org>2013-11-12 00:01:15 -0600
committerRobby Workman <rworkman@slackbuilds.org>2013-11-12 01:25:04 -0600
commitd06aa2e9314567147d551c3695a4c82dbd3c64b7 (patch)
tree32565934e0c3688b9d8c34d2b39f94c886b8b155 /system
parentfb12e1f0ddbed4aebd1d6f4e23061399ccc7deae (diff)
downloadslackbuilds-d06aa2e9314567147d551c3695a4c82dbd3c64b7.tar.gz
system/virtinst: Removed (part of virt-manager now)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/virtinst/README5
-rw-r--r--system/virtinst/slack-desc19
-rw-r--r--system/virtinst/virtinst.SlackBuild70
-rw-r--r--system/virtinst/virtinst.info10
4 files changed, 0 insertions, 104 deletions
diff --git a/system/virtinst/README b/system/virtinst/README
deleted file mode 100644
index 431bac176b..0000000000
--- a/system/virtinst/README
+++ /dev/null
@@ -1,5 +0,0 @@
-virtinst is a module to help in starting installations of Fedora/Red
-Hat Enterprise Linux related distributions inside of virtual
-machines. It supports both paravirt guests (for which only FC and
-RHEL guests are currently supported) as well as fully virtualized
-guests.
diff --git a/system/virtinst/slack-desc b/system/virtinst/slack-desc
deleted file mode 100644
index 5a865625d2..0000000000
--- a/system/virtinst/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-virtinst: virtinst (paravirtualization module)
-virtinst:
-virtinst: virtinst is a module to help in starting installations of Fedora/Red
-virtinst: Hat Enterprise Linux related distributions inside of virtual machines.
-virtinst: It supports both paravirt guests (for which only FC and RHEL guests
-virtinst: are currently supported) as well as fully virtualized guests. It
-virtinst: uses libvirt (http://www.libvirt.org) for starting things.
-virtinst:
-virtinst:
-virtinst:
-virtinst:
diff --git a/system/virtinst/virtinst.SlackBuild b/system/virtinst/virtinst.SlackBuild
deleted file mode 100644
index 6a8d03543b..0000000000
--- a/system/virtinst/virtinst.SlackBuild
+++ /dev/null
@@ -1,70 +0,0 @@
-#!/bin/sh
-
-PRGNAM=virtinst
-VERSION=${VERSION:-0.600.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root $PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Move and compress man pages
-mv $PKG/usr/share/man $PKG/usr
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS ChangeLog COPYING HACKING INSTALL NEWS PKG-INFO README \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/virtinst/virtinst.info b/system/virtinst/virtinst.info
deleted file mode 100644
index fca565cf95..0000000000
--- a/system/virtinst/virtinst.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="virtinst"
-VERSION="0.600.3"
-HOMEPAGE="http://virt-manager.et.redhat.com"
-DOWNLOAD="http://virt-manager.et.redhat.com/download/sources/virtinst/virtinst-0.600.3.tar.gz"
-MD5SUM="13c06b16c0f9fa23e7cb2534950b4575"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="libvirt"
-MAINTAINER="Zoran Stojakovic"
-EMAIL="stojakovic.zoran@gmail.com"