summaryrefslogtreecommitdiff
path: root/system/xen/patches
diff options
context:
space:
mode:
authorMario Preksavec <mario@slackware.hr>2021-10-16 11:12:05 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-10-18 07:50:31 +0700
commitb58940b86d93b1749eab3c75f33f272b4f95056a (patch)
tree67566adba6b69d963e262c1a8b95e2390c74d8ef /system/xen/patches
parent581d8490d19fe10273ec5df2581635b0af2f19d5 (diff)
downloadslackbuilds-b58940b86d93b1749eab3c75f33f272b4f95056a.tar.gz
system/xen: Updated for version 4.15.1.
Signed-off-by: Mario Preksavec <mario@slackware.hr> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/xen/patches')
-rw-r--r--system/xen/patches/ac9d413015d3bcf1e8f31cda764590b3ee949bc1.patch72
-rw-r--r--system/xen/patches/edk2-ovmf-202105-werror.patch38
-rw-r--r--system/xen/patches/tools-ipxe-update-for-fixing-build-with-GCC11.diff13
3 files changed, 51 insertions, 72 deletions
diff --git a/system/xen/patches/ac9d413015d3bcf1e8f31cda764590b3ee949bc1.patch b/system/xen/patches/ac9d413015d3bcf1e8f31cda764590b3ee949bc1.patch
deleted file mode 100644
index 32dcd67713..0000000000
--- a/system/xen/patches/ac9d413015d3bcf1e8f31cda764590b3ee949bc1.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-From ac9d413015d3bcf1e8f31cda764590b3ee949bc1 Mon Sep 17 00:00:00 2001
-From: Olaf Hering <olaf@aepfle.de>
-Date: Wed, 17 Jun 2020 08:13:49 +0200
-Subject: [PATCH] stubdom/vtpmmgr: simplify handling of hardware_version
-
-Remove complicated code which deals with a simple boolean, to make gcc10 happy.
-
-ld: /home/abuild/rpmbuild/BUILD/xen-4.14.20200616T103126.3625b04991/non-dbg/stubdom/vtpmmgr/vtpmmgr.a(vtpm_cmd_handler.o):(.bss+0x0): multiple definition of `tpm_version'; /home/abuild/rpmbuild/BUILD/xen-4.14.20200616T103126.3625b04991/non-dbg/stubdom/vtpmmgr/vtpmmgr.a(vtpmmgr.o):(.bss+0x0): first defined here
-
-Signed-off-by: Olaf Hering <olaf@aepfle.de>
-Message-Id: <20200617061349.7623-1-olaf@aepfle.de>
-Acked-by: Samuel Thibault <samuel.thibault@ens-lyon.org>
-Reviewed-by: Jason Andryuk <jandryuk@gmail.com>
----
- stubdom/vtpmmgr/vtpmmgr.c | 8 +++-----
- stubdom/vtpmmgr/vtpmmgr.h | 9 ---------
- 2 files changed, 3 insertions(+), 14 deletions(-)
-
-diff --git a/stubdom/vtpmmgr/vtpmmgr.c b/stubdom/vtpmmgr/vtpmmgr.c
-index 9fddaa24f818..94578adbffdd 100644
---- a/stubdom/vtpmmgr/vtpmmgr.c
-+++ b/stubdom/vtpmmgr/vtpmmgr.c
-@@ -45,9 +45,7 @@
- #include "vtpmmgr.h"
- #include "tcg.h"
-
--struct tpm_hardware_version hardware_version = {
-- .hw_version = TPM1_HARDWARE,
--};
-+static int hardware_version;
-
- int parse_cmdline_hw(int argc, char** argv)
- {
-@@ -55,7 +53,7 @@ int parse_cmdline_hw(int argc, char** argv)
-
- for (i = 1; i < argc; ++i) {
- if (!strcmp(argv[i], TPM2_EXTRA_OPT)) {
-- hardware_version.hw_version = TPM2_HARDWARE;
-+ hardware_version = 2;
- break;
- }
- }
-@@ -64,7 +62,7 @@ int parse_cmdline_hw(int argc, char** argv)
-
- int hw_is_tpm2(void)
- {
-- return (hardware_version.hw_version == TPM2_HARDWARE) ? 1 : 0;
-+ return hardware_version == 2 ? 1 : 0;
- }
-
- void main_loop(void) {
-diff --git a/stubdom/vtpmmgr/vtpmmgr.h b/stubdom/vtpmmgr/vtpmmgr.h
-index 2e6f8de9e435..6523604bdcf2 100644
---- a/stubdom/vtpmmgr/vtpmmgr.h
-+++ b/stubdom/vtpmmgr/vtpmmgr.h
-@@ -50,16 +50,7 @@
- #define RSA_KEY_SIZE 0x0800
- #define RSA_CIPHER_SIZE (RSA_KEY_SIZE / 8)
-
--enum {
-- TPM1_HARDWARE = 1,
-- TPM2_HARDWARE,
--} tpm_version;
-
--struct tpm_hardware_version {
-- int hw_version;
--};
--
--extern struct tpm_hardware_version hardware_version;
-
- struct vtpm_globals {
- int tpm_fd;
diff --git a/system/xen/patches/edk2-ovmf-202105-werror.patch b/system/xen/patches/edk2-ovmf-202105-werror.patch
new file mode 100644
index 0000000000..db71faed77
--- /dev/null
+++ b/system/xen/patches/edk2-ovmf-202105-werror.patch
@@ -0,0 +1,38 @@
+diff --git a/BaseTools/Conf/tools_def.template b/BaseTools/Conf/tools_def.template
+index 498696e..8a360f4 100755
+--- a/BaseTools/Conf/tools_def.template
++++ b/BaseTools/Conf/tools_def.template
+@@ -1863,7 +1863,7 @@ NOOPT_*_*_OBJCOPY_ADDDEBUGFLAG = --add-gnu-debuglink=$(DEBUG_DIR)/$(MODULE_N
+ *_*_*_DTCPP_PATH = DEF(DTCPP_BIN)
+ *_*_*_DTC_PATH = DEF(DTC_BIN)
+
+-DEFINE GCC_ALL_CC_FLAGS = -g -Os -fshort-wchar -fno-builtin -fno-strict-aliasing -Wall -Werror -Wno-array-bounds -include AutoGen.h -fno-common
++DEFINE GCC_ALL_CC_FLAGS = -g -Os -fshort-wchar -fno-builtin -fno-strict-aliasing -Wall -Wno-array-bounds -include AutoGen.h -fno-common
+ DEFINE GCC_IA32_CC_FLAGS = DEF(GCC_ALL_CC_FLAGS) -m32 -malign-double -freorder-blocks -freorder-blocks-and-partition -O2 -mno-stack-arg-probe
+ DEFINE GCC_X64_CC_FLAGS = DEF(GCC_ALL_CC_FLAGS) -mno-red-zone -Wno-address -mno-stack-arg-probe
+ DEFINE GCC_ARM_CC_FLAGS = DEF(GCC_ALL_CC_FLAGS) -mlittle-endian -mabi=aapcs -fno-short-enums -funsigned-char -ffunction-sections -fdata-sections -fomit-frame-pointer -Wno-address -mthumb -mfloat-abi=soft -fno-pic -fno-pie
+diff --git a/BaseTools/Source/C/Makefiles/header.makefile b/BaseTools/Source/C/Makefiles/header.makefile
+index 0df728f..49f9706 100644
+--- a/BaseTools/Source/C/Makefiles/header.makefile
++++ b/BaseTools/Source/C/Makefiles/header.makefile
+@@ -82,17 +82,17 @@ BUILD_OPTFLAGS = -O2 $(EXTRA_OPTFLAGS)
+
+ ifeq ($(DARWIN),Darwin)
+ # assume clang or clang compatible flags on OS X
+-BUILD_CFLAGS = -MD -fshort-wchar -fno-strict-aliasing -Wall -Werror \
++BUILD_CFLAGS = -MD -fshort-wchar -fno-strict-aliasing -Wall \
+ -Wno-deprecated-declarations -Wno-self-assign -Wno-unused-result -nostdlib -g
+ else
+ ifeq ($(CXX), llvm)
+ BUILD_CFLAGS = -MD -fshort-wchar -fno-strict-aliasing -fwrapv \
+--fno-delete-null-pointer-checks -Wall -Werror \
++-fno-delete-null-pointer-checks -Wall \
+ -Wno-deprecated-declarations -Wno-self-assign \
+ -Wno-unused-result -nostdlib -g
+ else
+ BUILD_CFLAGS = -MD -fshort-wchar -fno-strict-aliasing -fwrapv \
+--fno-delete-null-pointer-checks -Wall -Werror \
++-fno-delete-null-pointer-checks -Wall \
+ -Wno-deprecated-declarations -Wno-stringop-truncation -Wno-restrict \
+ -Wno-unused-result -nostdlib -g
+ endif
diff --git a/system/xen/patches/tools-ipxe-update-for-fixing-build-with-GCC11.diff b/system/xen/patches/tools-ipxe-update-for-fixing-build-with-GCC11.diff
new file mode 100644
index 0000000000..b7fab4dd6e
--- /dev/null
+++ b/system/xen/patches/tools-ipxe-update-for-fixing-build-with-GCC11.diff
@@ -0,0 +1,13 @@
+diff --git a/tools/firmware/etherboot/Makefile b/tools/firmware/etherboot/Makefile
+index ed9e11305f..4bc3633ba3 100644
+--- a/tools/firmware/etherboot/Makefile
++++ b/tools/firmware/etherboot/Makefile
+@@ -10,7 +10,8 @@ else
+ IPXE_GIT_URL ?= git://git.ipxe.org/ipxe.git
+ endif
+
+-IPXE_GIT_TAG := 988d2c13cdf0f0b4140685af35ced70ac5b3283c
++# put an updated tar.gz on xenbits after changes to this variable
++IPXE_GIT_TAG := 3c040ad387099483102708bb1839110bc788cefb
+
+ IPXE_TARBALL_URL ?= $(XEN_EXTFILES_URL)/ipxe-git-$(IPXE_GIT_TAG).tar.gz