summaryrefslogtreecommitdiff
path: root/system/spambayes/spambayes.SlackBuild
diff options
context:
space:
mode:
authorAudrius Kažukauskas <audrius@neutrino.lt>2010-05-12 17:46:01 +0200
committerDavid Somero <xgizzmo@slackbuilds.org>2010-05-12 17:46:01 +0200
commit38ecf19e26be907e7205e22bd868723a48f9c9e1 (patch)
tree9af25137d76e4e57e8b795d30c6e6ae551b4c6b0 /system/spambayes/spambayes.SlackBuild
parent27846f207a9ae404b35ab292472b54f2234051a8 (diff)
downloadslackbuilds-38ecf19e26be907e7205e22bd868723a48f9c9e1.tar.gz
system/spambayes: Updated for version 1.0.4
Diffstat (limited to 'system/spambayes/spambayes.SlackBuild')
-rw-r--r--system/spambayes/spambayes.SlackBuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/system/spambayes/spambayes.SlackBuild b/system/spambayes/spambayes.SlackBuild
index 687f6b9230..9e4d79be6d 100644
--- a/system/spambayes/spambayes.SlackBuild
+++ b/system/spambayes/spambayes.SlackBuild
@@ -1,36 +1,39 @@
#!/bin/sh
# Slackware build script for spambayes
-
-# Copyright (c) 2007 Audrius Kažukauskas <neobug@tornado.ktu.lt>
-
-set -e
+# Written by Audrius Kažukauskas <audrius@neutrino.lt>
PRGNAM=spambayes
-VERSION=1.0.4
+VERSION=${VERSION:-1.0.4}
ARCH=noarch
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
-CWD=`pwd`
+
+CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+set -eu
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
-
chown -R root:root .
chmod -R u+rw,go+r-w,a-s .
+# Eliminate deprecation warning for sets module with Python 2.6
+sed -i 's/from sets import Set/Set = set/' \
+ spambayes/{classifier.py,TestDriver.py,tokenizer.py,ProxyUI.py}
+
python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- CHANGELOG.txt LICENSE.txt NEWTRICKS.txt PKG-INFO POP3PROXY.txt \
+ CHANGELOG.txt LICENSE.txt NEWTRICKS.txt POP3PROXY.txt \
README-DEVEL.txt README.txt TESTING.txt WHAT_IS_NEW.txt \
$PKG/usr/doc/$PRGNAM-$VERSION
cp -a contrib $PKG/usr/doc/$PRGNAM-$VERSION