summaryrefslogtreecommitdiff
path: root/system/rdiff-backup/rdiff-backup.SlackBuild
diff options
context:
space:
mode:
authorPaul Wisehart <wise@lupulin.net>2010-05-13 00:41:36 +0200
committerDavid Somero <xgizzmo@slackbuilds.org>2010-05-13 00:41:36 +0200
commit1e9048c103294d56183e80413c946c4d1ba55a9c (patch)
treef8a01d6806c5af1d33824425e39b307b951ecab3 /system/rdiff-backup/rdiff-backup.SlackBuild
parent0074467c1fcb49d853f46138d235cadb0e7338a6 (diff)
downloadslackbuilds-1e9048c103294d56183e80413c946c4d1ba55a9c.tar.gz
system/rdiff-backup: Updated for version 1.2.8
Diffstat (limited to 'system/rdiff-backup/rdiff-backup.SlackBuild')
-rw-r--r--system/rdiff-backup/rdiff-backup.SlackBuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/system/rdiff-backup/rdiff-backup.SlackBuild b/system/rdiff-backup/rdiff-backup.SlackBuild
index 84f6cff150..1c3a983b22 100644
--- a/system/rdiff-backup/rdiff-backup.SlackBuild
+++ b/system/rdiff-backup/rdiff-backup.SlackBuild
@@ -24,13 +24,13 @@
# Modified by the SlackBuilds.org project
PRGNAM=rdiff-backup
-VERSION=1.2.5
-ARCH=noarch
+VERSION=1.2.8
+ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
TMP=${TMP:-/tmp/SBo}
-CWD=$(pwd)
+CWD=$(pwd)
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -43,14 +43,14 @@ cd $PRGNAM-$VERSION || exit 1
chown -R root:root .
chmod -R a-s,u+rw,go-w+r .
-sed -i 's|share/man/|man/|g' setup.py
-python setup.py install --prefix=/usr --root=$PKG
+sed -i 's|share/man/|man/|g' setup.py || exit 1
+python setup.py install --prefix=/usr --root=$PKG || exit 1
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
+ xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
+ xargs strip --strip-unneeded 2> /dev/null || true
)
( cd $PKG/usr/man
@@ -68,4 +68,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}