summaryrefslogtreecommitdiff
path: root/system/glances/glances.SlackBuild
diff options
context:
space:
mode:
authorPhilip Lacroix <philnx at posteo dot de>2015-02-07 06:33:57 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2015-02-07 06:33:57 +0700
commitade70ab197ad52e8e7a2c7652e4cc0ac83fcb3be (patch)
treeaf9090c0a718bc104e146bf9f46adda924b3a848 /system/glances/glances.SlackBuild
parent610988b2e954ad55a8ff4be76cd3675c812a9a02 (diff)
downloadslackbuilds-ade70ab197ad52e8e7a2c7652e4cc0ac83fcb3be.tar.gz
system/glances: Updated for version 2.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/glances/glances.SlackBuild')
-rw-r--r--system/glances/glances.SlackBuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/system/glances/glances.SlackBuild b/system/glances/glances.SlackBuild
index 3d5f740f0c..be96646c42 100644
--- a/system/glances/glances.SlackBuild
+++ b/system/glances/glances.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for glances
-# Copyright 2013-2014 Philip Lacroix <philnx at posteo dot de>
+# Copyright 2013-2015 Philip Lacroix <philnx at posteo dot de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=glances
-VERSION=${VERSION:-2.2.1}
+VERSION=${VERSION:-2.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -47,8 +47,8 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-# The tarball will be named differently, depending on the file being downloaded
-# manually or with wget.
+# The upstream tarball will be named differently, depending on the file being
+# downloaded manually (web browser) or with wget.
if [ -e $CWD/v$VERSION.tar.gz ]; then
tar xvf $CWD/v$VERSION.tar.gz
else
@@ -70,7 +70,7 @@ PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
python setup.py install --root=$PKG
-# Python 3 support
+# Python 3 support.
if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
@@ -79,6 +79,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null \
|| true
+# Don't mess with existing config files.
mv $PRGETC/$PRGNAM.conf $PRGETC/$PRGNAM.conf.new
mv $PRGSHR/man $PKG/usr/