summaryrefslogtreecommitdiff
path: root/python/python2-chardet
diff options
context:
space:
mode:
authorMikko Värri <vmj@linuxbox.fi>2014-01-25 01:22:54 +0700
committerErik Hanson <erik@slackbuilds.org>2014-01-29 23:21:12 -0600
commitf678d5161b39d06439b4aff534fc8e6463031eef (patch)
tree1b7469ebae09bb4067d123efebc1d8b5e781e0e5 /python/python2-chardet
parent76cb33b579a6e3de3f1d4f9c95de192bc97ad226 (diff)
downloadslackbuilds-f678d5161b39d06439b4aff534fc8e6463031eef.tar.gz
python/python-chardet : Added (renamed from python2-chardet).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-chardet')
-rw-r--r--python/python2-chardet/README1
-rw-r--r--python/python2-chardet/python2-chardet.SlackBuild72
-rw-r--r--python/python2-chardet/python2-chardet.info10
-rw-r--r--python/python2-chardet/slack-desc19
4 files changed, 0 insertions, 102 deletions
diff --git a/python/python2-chardet/README b/python/python2-chardet/README
deleted file mode 100644
index c834c08942..0000000000
--- a/python/python2-chardet/README
+++ /dev/null
@@ -1 +0,0 @@
-Character encoding auto-detection in Python for Python 2.x.
diff --git a/python/python2-chardet/python2-chardet.SlackBuild b/python/python2-chardet/python2-chardet.SlackBuild
deleted file mode 100644
index 63a7882f61..0000000000
--- a/python/python2-chardet/python2-chardet.SlackBuild
+++ /dev/null
@@ -1,72 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python2-chardet
-
-# Copyright 2011 Mikko Värri, Finland
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python2-chardet
-SRCNAM=chardet
-VERSION=${VERSION:-2.1.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING docs/* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python2-chardet/python2-chardet.info b/python/python2-chardet/python2-chardet.info
deleted file mode 100644
index 0dbd696306..0000000000
--- a/python/python2-chardet/python2-chardet.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python2-chardet"
-VERSION="2.1.1"
-HOMEPAGE="https://pypi.python.org/pypi/chardet"
-DOWNLOAD="https://pypi.python.org/packages/source/c/chardet/chardet-2.1.1.tar.gz"
-MD5SUM="295367fd210d20f3febda615a88e1ef0"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pysetuptools"
-MAINTAINER="Mikko Värri"
-EMAIL="vmj@linuxbox.fi"
diff --git a/python/python2-chardet/slack-desc b/python/python2-chardet/slack-desc
deleted file mode 100644
index 93a3d20f44..0000000000
--- a/python/python2-chardet/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python2-chardet: python2-chardet (autodetection of character encoding in python)
-python2-chardet:
-python2-chardet: Character encoding auto-detection in Python for Python 2.x.
-python2-chardet:
-python2-chardet: Homepage: https://pypi.python.org/pypi/chardet
-python2-chardet:
-python2-chardet:
-python2-chardet:
-python2-chardet:
-python2-chardet:
-python2-chardet: