summaryrefslogtreecommitdiff
path: root/python/python2-chardet/python2-chardet.SlackBuild
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2013-11-13 19:37:34 +0700
committerRobby Workman <rworkman@slackbuilds.org>2013-11-13 11:19:03 -0600
commitafc907a2413be78254f3589dc77ed353d3e2dad7 (patch)
tree082c6bc36079c43a8734e32d93c5c6e2171c2819 /python/python2-chardet/python2-chardet.SlackBuild
parent4687c9b5268930440b12bfcca420ad432f410cbc (diff)
downloadslackbuilds-afc907a2413be78254f3589dc77ed353d3e2dad7.tar.gz
python/python2-chardet: Updated for version 2.1.1
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-chardet/python2-chardet.SlackBuild')
-rw-r--r--python/python2-chardet/python2-chardet.SlackBuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/python/python2-chardet/python2-chardet.SlackBuild b/python/python2-chardet/python2-chardet.SlackBuild
index 9df08de091..63a7882f61 100644
--- a/python/python2-chardet/python2-chardet.SlackBuild
+++ b/python/python2-chardet/python2-chardet.SlackBuild
@@ -23,16 +23,15 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python2-chardet
-VERSION=${VERSION:-2.0.1}
+SRCNAM=chardet
+VERSION=${VERSION:-2.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -47,15 +46,15 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tgz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG