summaryrefslogtreecommitdiff
path: root/python/python-elementtree
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-03 06:50:13 +0100
committerRobby Workman <rworkman@slackbuilds.org>2021-05-03 01:49:57 -0500
commitcd9dfdc586c9b1d35c5e9b2990febfc13dae4880 (patch)
tree6c5980e2996304499377ff7d16865bdf0a31260c /python/python-elementtree
parentb7c28a1972b5126ca59419054b2674bfec64a4a2 (diff)
downloadslackbuilds-cd9dfdc586c9b1d35c5e9b2990febfc13dae4880.tar.gz
python/python-elementtree: Renamed python2-elementtree.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'python/python-elementtree')
-rw-r--r--python/python-elementtree/README7
-rw-r--r--python/python-elementtree/python-elementtree.SlackBuild76
-rw-r--r--python/python-elementtree/python-elementtree.info10
-rw-r--r--python/python-elementtree/slack-desc19
4 files changed, 0 insertions, 112 deletions
diff --git a/python/python-elementtree/README b/python/python-elementtree/README
deleted file mode 100644
index e0c761f808..0000000000
--- a/python/python-elementtree/README
+++ /dev/null
@@ -1,7 +0,0 @@
-The Element type is a simple but flexible container object, designed
-to store hierarchical data structures, such as simplified XML
-infosets, in memory. The element type can be described as a cross
-between a Python list and a Python dictionary.
-
-The ElementTree wrapper type adds code to load XML files as trees of
-Element objects, and save them back again.
diff --git a/python/python-elementtree/python-elementtree.SlackBuild b/python/python-elementtree/python-elementtree.SlackBuild
deleted file mode 100644
index e499e891f5..0000000000
--- a/python/python-elementtree/python-elementtree.SlackBuild
+++ /dev/null
@@ -1,76 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for elementtree
-
-# Copyright 2010 David Woodfall <dave@slackbuilds.org>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-elementtree
-VERSION=${VERSION:-1.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-COMMIT=405fb0295388a54104f3641eedfeb4c8a3e1ae4d
-SRCNAM=py-elementtree
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$COMMIT
-tar xvf $CWD/$SRCNAM-$COMMIT.tar.gz
-cd $SRCNAM-$COMMIT
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGES README \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-elementtree/python-elementtree.info b/python/python-elementtree/python-elementtree.info
deleted file mode 100644
index 9977ee0590..0000000000
--- a/python/python-elementtree/python-elementtree.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-elementtree"
-VERSION="1.3"
-HOMEPAGE="http://effbot.org/zone/element-index.htm"
-DOWNLOAD="https://github.com/vkris/py-elementtree/archive/405fb0295388a54104f3641eedfeb4c8a3e1ae4d/py-elementtree-405fb0295388a54104f3641eedfeb4c8a3e1ae4d.tar.gz"
-MD5SUM="c40a3521424528e32f0998e31a3b36f3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="David Woodfall"
-EMAIL="dave@slackbuilds.org"
diff --git a/python/python-elementtree/slack-desc b/python/python-elementtree/slack-desc
deleted file mode 100644
index 875c823cd1..0000000000
--- a/python/python-elementtree/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-elementtree: python-elementtree (Python library wrapper for XML)
-python-elementtree:
-python-elementtree: The Element type is a simple but flexible container object, designed
-python-elementtree: to store hierarchical data structures, such as simplified XML
-python-elementtree: infosets, in memory. The element type can be described as a cross
-python-elementtree: between a Python list and a Python dictionary.
-python-elementtree:
-python-elementtree: The ElementTree wrapper type adds code to load XML files as trees of
-python-elementtree: Element objects, and save them back again.
-python-elementtree:
-python-elementtree: Homepage: http://effbot.org/zone/element-index.htm