summaryrefslogtreecommitdiff
path: root/python/python-dateutil/python-dateutil.SlackBuild
diff options
context:
space:
mode:
authorLarry Hajali <larryhaja[at]gmail[dot]com>2012-12-27 07:56:31 +0100
committerMatteo Bernardini <ponce@slackbuilds.org>2012-12-27 17:56:20 +0100
commitc1a8fd49940a63b583b61403d3da5a8eb354b46a (patch)
treea3c90ee38b4662634bdcf73561f46d72bf22a71a /python/python-dateutil/python-dateutil.SlackBuild
parent669a30ce99229883d6df0e2c6ef6bbd2fb81d744 (diff)
downloadslackbuilds-c1a8fd49940a63b583b61403d3da5a8eb354b46a.tar.gz
python/python-dateutil: Updated for version 2.1, added license.
Also added the new dependency six Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'python/python-dateutil/python-dateutil.SlackBuild')
-rw-r--r--python/python-dateutil/python-dateutil.SlackBuild29
1 files changed, 24 insertions, 5 deletions
diff --git a/python/python-dateutil/python-dateutil.SlackBuild b/python/python-dateutil/python-dateutil.SlackBuild
index f8f949ce34..b0e6e3e7c6 100644
--- a/python/python-dateutil/python-dateutil.SlackBuild
+++ b/python/python-dateutil/python-dateutil.SlackBuild
@@ -2,19 +2,35 @@
# Slackware build script for python-dateutil
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-dateutil
-VERSION=1.5
+VERSION=${VERSION:-2.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -39,13 +55,16 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Fix UnicodeDecodeError in setup.py. From upstream.
+patch -p0 < $CWD/python-dateutil-2.1-open-utf-8.patch
+
python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE NEWS PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install