summaryrefslogtreecommitdiff
path: root/network/youtube-dl/youtube-dl.SlackBuild
diff options
context:
space:
mode:
authorDimitris Zlatanidis <d.zlatanidis@gmail.com>2015-03-02 00:23:49 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2015-03-02 00:23:49 +0700
commit24286119a0252a683d8bcdb3e8954d74c22306e0 (patch)
treec77ef39e6d856ab4155ddce7816ceab45337565d /network/youtube-dl/youtube-dl.SlackBuild
parente18f3c62b13d343e48d92b32a8023c53b7cc7a77 (diff)
downloadslackbuilds-24286119a0252a683d8bcdb3e8954d74c22306e0.tar.gz
network/youtube-dl: Updated for version 2015.02.28.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network/youtube-dl/youtube-dl.SlackBuild')
-rw-r--r--network/youtube-dl/youtube-dl.SlackBuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/network/youtube-dl/youtube-dl.SlackBuild b/network/youtube-dl/youtube-dl.SlackBuild
index a27b3fe82e..15a8ba1f24 100644
--- a/network/youtube-dl/youtube-dl.SlackBuild
+++ b/network/youtube-dl/youtube-dl.SlackBuild
@@ -24,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=youtube-dl
-VERSION=${VERSION:-2015.02.21}
+VERSION=${VERSION:-2015.02.28}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,20 +71,23 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Makefile patch
-patch -p1 < $CWD/Makefile.patch
-
# setup.py patch
patch -p1 < $CWD/setup.patch
make
python setup.py install --root=$PKG
+# enable bash and fish completion file
+chmod +x $PKG/etc/bash_completion.d/${PRGNAM}.bash-completion
+chmod +x $PKG/etc/fish/completions/${PRGNAM}.fish
+
# install man page
mkdir -p $PKG/usr/man/man1
install -D -m0644 $CWD/$PRGNAM.1 $PKG/usr/man/man1/$PRGNAM.1
gzip -9 $PKG/usr/man/man1/$PRGNAM.1
+rm -rf $PKG/share
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true