summaryrefslogtreecommitdiff
path: root/network/exim/exim.SlackBuild
diff options
context:
space:
mode:
authorThomas Morper <thomas@beingboiled.info>2012-06-30 12:07:31 -0400
committerdsomero <xgizzmo@slackbuilds.org>2012-06-30 12:07:31 -0400
commit585c78f0a98d34e1c7e0793ca2adaf60a8cb6ed5 (patch)
treed2d3b643fdf211dc6d93d76aa54bfa7aee793346 /network/exim/exim.SlackBuild
parent647fb6daaecb190a10fbcd823da7902d8bf57628 (diff)
downloadslackbuilds-585c78f0a98d34e1c7e0793ca2adaf60a8cb6ed5.tar.gz
network/exim: Updated for version 4.80.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'network/exim/exim.SlackBuild')
-rw-r--r--network/exim/exim.SlackBuild40
1 files changed, 32 insertions, 8 deletions
diff --git a/network/exim/exim.SlackBuild b/network/exim/exim.SlackBuild
index be60519268..ad974a6555 100644
--- a/network/exim/exim.SlackBuild
+++ b/network/exim/exim.SlackBuild
@@ -1,23 +1,37 @@
#!/bin/sh
+# vim: ts=2 sts=2 sw=2 expandtab
# Slackware build script for Exim
-# Written by Thomas Morper <thomas@beingboiled.info>
-# Thanks to Thales A. Tsailas <ttsailas@enforcingit.com> and the SBo team
-# for the previous version and the accompanying files.
-# Thanks to Debian for the manpages.
+# Copyright 2012 Thomas Morper, Augsburg, Germany
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=exim
-VERSION=${VERSION:-4.77}
+VERSION=${VERSION:-4.80}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -61,8 +75,18 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Copy the Makefile and a stock config for eximon
+# This is our custom config for an all-purpose Exim daemon.
+# The SQL- and LDAP-lookups will not be built by default,
+# but you can enable them easily by passing the directives
+# on the command line when calling this script, e.g.
+#
+# LOOKUP_LDAP=yes LOOKUP_SQLITE=yes \
+# LOOKUP_MYSQL=yes LOOKUP_POSTGRES=yes \
+# sh exim.SlackBuild
+#
cat $CWD/exim.Makefile > Local/Makefile
+
+# Use a stock config for the Exim Monitor (not built by default).
cat exim_monitor/EDITME > Local/eximon.conf
# Use the Exim build system to set the architecture-specific CFLAGS.