summaryrefslogtreecommitdiff
path: root/multimedia/xbmc/patches
diff options
context:
space:
mode:
authorLarry Hajali <larryhaja[at]gmail[dot]com>2013-02-19 23:02:47 -0600
committerRobby Workman <rworkman@slackbuilds.org>2013-02-22 22:27:47 -0600
commit18b442c44cd27bcbb95e75a50f61a731015005a0 (patch)
treefae5cab06f07fdc1422ad18d7354f33c3c8f5a21 /multimedia/xbmc/patches
parentca3d9c6f1ce13f455922510371ef4781bb5347ff (diff)
downloadslackbuilds-18b442c44cd27bcbb95e75a50f61a731015005a0.tar.gz
multimedia/xbmc: Updated for version 12.0.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'multimedia/xbmc/patches')
-rw-r--r--multimedia/xbmc/patches/cwiid-old-api.patch16
-rw-r--r--multimedia/xbmc/patches/non-sse2-cpu.patch21
-rw-r--r--multimedia/xbmc/patches/sse2.patch12
-rw-r--r--multimedia/xbmc/patches/system-includes.patch19
4 files changed, 28 insertions, 40 deletions
diff --git a/multimedia/xbmc/patches/cwiid-old-api.patch b/multimedia/xbmc/patches/cwiid-old-api.patch
new file mode 100644
index 0000000000..a9cb4431cb
--- /dev/null
+++ b/multimedia/xbmc/patches/cwiid-old-api.patch
@@ -0,0 +1,16 @@
+diff -Naur xbmc-12.0.orig/tools/EventClients/Clients/WiiRemote/CWIID_WiiRemote.cpp xbmc-12.0/tools/EventClients/Clients/WiiRemote/CWIID_WiiRemote.cpp
+--- xbmc-12.0.orig/tools/EventClients/Clients/WiiRemote/CWIID_WiiRemote.cpp 2013-01-29 14:20:27.000000000 +0000
++++ xbmc-12.0/tools/EventClients/Clients/WiiRemote/CWIID_WiiRemote.cpp 2013-02-02 23:13:08.422456751 +0000
+@@ -100,9 +100,11 @@
+ g_WiiRemote.ProcessNunchuck(mesg[i].nunchuk_mesg);
+ break;
+ case CWIID_MESG_ACC:
+- case CWIID_MESG_BALANCE:
+ case CWIID_MESG_CLASSIC:
++#ifndef CWIID_OLD
++ case CWIID_MESG_BALANCE:
+ case CWIID_MESG_MOTIONPLUS:
++#endif
+ //Not implemented
+ break;
+ case CWIID_MESG_UNKNOWN:
diff --git a/multimedia/xbmc/patches/non-sse2-cpu.patch b/multimedia/xbmc/patches/non-sse2-cpu.patch
deleted file mode 100644
index ebf927c1ac..0000000000
--- a/multimedia/xbmc/patches/non-sse2-cpu.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur xbmc-11.0-Eden_beta1.orig/lib/libsquish/Makefile.in xbmc-11.0-Eden_beta1/lib/libsquish/Makefile.in
---- xbmc-11.0-Eden_beta1.orig/lib/libsquish/Makefile.in 2011-12-23 03:12:21.000000000 +0000
-+++ xbmc-11.0-Eden_beta1/lib/libsquish/Makefile.in 2012-01-02 20:14:20.792407216 +0000
-@@ -15,7 +15,7 @@
- ifeq ($(findstring powerpc,$(ARCH)),powerpc)
- CXXFLAGS+=-DSQUISH_USE_ALTIVEC=1 -maltivec
- else ifeq ($(findstring x86,$(ARCH)), x86)
-- CXXFLAGS+=-DSQUISH_USE_SSE=2 -msse2
-+ CXXFLAGS+=-DSQUISH_USE_SSE=1 -msse
- endif
-
- LIB=libsquish.a
-@@ -30,7 +30,7 @@
- ifeq ($(findstring osx,$(ARCH)),osx)
- g++ -m32 -DSQUISH_USE_SSE=2 -msse2 -I. $(SRCS) -dynamiclib -install_name `pwd`/libsquish-native.so -o $@
- else
-- g++ -DSQUISH_USE_SSE=2 -msse2 -I. $(SRCS) -shared -fPIC -Wl,-soname,`pwd`/libsquish-native.so -o $@
-+ g++ -DSQUISH_USE_SSE=1 -msse -I. $(SRCS) -shared -fPIC -Wl,-soname,`pwd`/libsquish-native.so -o $@
- endif
- endif
-
diff --git a/multimedia/xbmc/patches/sse2.patch b/multimedia/xbmc/patches/sse2.patch
new file mode 100644
index 0000000000..d9b730ed2f
--- /dev/null
+++ b/multimedia/xbmc/patches/sse2.patch
@@ -0,0 +1,12 @@
+diff -Naur Git-xbmc.orig/lib/libsquish/config Git-xbmc/lib/libsquish/config
+--- Git-xbmc.orig/lib/libsquish/config 2012-11-18 14:14:35.000000000 +0000
++++ Git-xbmc/lib/libsquish/config 2012-12-07 02:54:22.864062271 +0000
+@@ -4,7 +4,7 @@
+ USE_ALTIVEC ?= 0
+
+ # define to 1 to use SSE2 instructions
+-USE_SSE ?= 0
++USE_SSE ?= 1
+
+ # default flags
+ CXXFLAGS ?= -O2
diff --git a/multimedia/xbmc/patches/system-includes.patch b/multimedia/xbmc/patches/system-includes.patch
deleted file mode 100644
index 8c076b36d4..0000000000
--- a/multimedia/xbmc/patches/system-includes.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -Naur xbmc-11.0-Eden_beta1.orig/Makefile.include.in xbmc-11.0-Eden_beta1/Makefile.include.in
---- xbmc-11.0-Eden_beta1.orig/Makefile.include.in 2011-12-23 03:12:21.000000000 +0000
-+++ xbmc-11.0-Eden_beta1/Makefile.include.in 2012-01-02 22:07:34.114048145 +0000
-@@ -32,7 +32,6 @@
- CXXFLAGS+=@CXXFLAGS@
- CFLAGS+=@CFLAGS@
- LDFLAGS+=@LDFLAGS@
--INCLUDES+=$(sort @INCLUDES@)
- INCLUDES+=-I@abs_top_srcdir@/lib
- INCLUDES+=-I@abs_top_srcdir@/xbmc
- ifneq (@USE_EXTERNAL_FFMPEG@,1)
-@@ -40,6 +39,7 @@
- endif
- INCLUDES+=-I@abs_top_srcdir@/xbmc/linux
- INCLUDES+=-I@abs_top_srcdir@/xbmc/cores/dvdplayer
-+INCLUDES+=$(sort @INCLUDES@)
- DEFINES+= \
- @ARCH_DEFINES@ \
- -D_FILE_DEFINED \