summaryrefslogtreecommitdiff
path: root/multimedia/openshot/openshot.SlackBuild
diff options
context:
space:
mode:
authorChristoph Willing <chris.willing@iinet.net.au>2016-10-25 10:09:14 +1000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-29 06:58:35 +0700
commit8c517c91b65fe280fe66114555ab3b62fd0983bd (patch)
tree3cee88e678a40efc1f96309f69c0e18e01d86c8e /multimedia/openshot/openshot.SlackBuild
parent528bb534649808d099c941da3ac9674a61d32256 (diff)
downloadslackbuilds-8c517c91b65fe280fe66114555ab3b62fd0983bd.tar.gz
multimedia/openshot: Updated for version 2.1.0. New maintainer
Signed-off-by: Christoph Willing <chris.willing@iinet.net.au>
Diffstat (limited to 'multimedia/openshot/openshot.SlackBuild')
-rw-r--r--multimedia/openshot/openshot.SlackBuild29
1 files changed, 14 insertions, 15 deletions
diff --git a/multimedia/openshot/openshot.SlackBuild b/multimedia/openshot/openshot.SlackBuild
index aeb8955005..ef0b200878 100644
--- a/multimedia/openshot/openshot.SlackBuild
+++ b/multimedia/openshot/openshot.SlackBuild
@@ -2,6 +2,8 @@
# Copyright 2009, Jonathan Larsen (agentc0re), SLC, UT
# Contact Info: agentc0re 'AT' learnix 'DOT' net
+#
+# Copyright 2016 Christoph Willing Brisbane, Australia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -38,15 +40,19 @@
#
# Oct 2nd, 2012
# Version upgrade to 1.4.3 - Matteo Bernardini <ponce@slackbuilds.org>
+#
+# Oct 22nd, 2016
+# Version upgrade to 2.1.0 - Christoph Willing <chris.willing@linux.com>
PRGNAM=openshot
-VERSION=1.4.3
+SRCNAM=openshot-qt
+VERSION=2.1.0
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -57,8 +63,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -77,9 +83,9 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -87,20 +93,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# mkdir -p $PKG/usr/man
-mv $PKG/usr/share/man $PKG/usr/
-rm -rf $PKG/usr/share/man
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cd $TMP/$PRGNAM-$VERSION
cp -a AUTHORS COPYING README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild