summaryrefslogtreecommitdiff
path: root/multimedia/kaffeine/CMakeLists.patch
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2016-01-05 19:26:57 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2016-01-17 09:40:16 +0700
commit4710ee3fa730dcc37d1c6430741e0db2c59e3296 (patch)
tree149748bee5dc5703d922cfa22652ca289ae453bc /multimedia/kaffeine/CMakeLists.patch
parentc58bc4ec30c7aab3553a14eef50cd18e59f753d3 (diff)
downloadslackbuilds-4710ee3fa730dcc37d1c6430741e0db2c59e3296.tar.gz
multimedia/kaffeine: Updated for version 1.3.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia/kaffeine/CMakeLists.patch')
-rw-r--r--multimedia/kaffeine/CMakeLists.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/multimedia/kaffeine/CMakeLists.patch b/multimedia/kaffeine/CMakeLists.patch
new file mode 100644
index 0000000000..d70973660e
--- /dev/null
+++ b/multimedia/kaffeine/CMakeLists.patch
@@ -0,0 +1,24 @@
+From 4a1a90ee1b2b4d13302046f043adf1c2a1de758d Mon Sep 17 00:00:00 2001
+From: Raphael Kubo da Costa <rakuco@FreeBSD.org>
+Date: Thu, 26 Nov 2015 15:36:26 +0100
+Subject: [PATCH] Explicitly include CheckIncludeFiles.
+
+This fixes the build with CMake 3.4.0. We were calling check_include_files()
+and implicitly relying on CheckIncludeFiles being included.
+---
+ CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d9be8db..b74b44d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -21,6 +21,7 @@ if(STRICT_BUILD)
+ -DQT_NO_URL_CAST_FROM_STRING -DQT_STRICT_ITERATORS)
+ endif(STRICT_BUILD)
+
++include(CheckIncludeFiles)
+ check_include_files(${CMAKE_CURRENT_SOURCE_DIR}/include/frontend.h HAVE_DVB)
+
+ if(NOT HAVE_DVB)
+