summaryrefslogtreecommitdiff
path: root/misc/funny-manpages/funny-manpages.SlackBuild
diff options
context:
space:
mode:
authorMichiel van Wessem <michiel@slackbuilds.org>2010-05-11 22:54:28 +0200
committerRobby Workman <rworkman@slackbuilds.org>2010-05-11 22:54:28 +0200
commit1ce14296d1cee7c2cc925c94fdcca5de40930d8c (patch)
tree0a4a2c020115c651645331c3643ff2f943b3e7d0 /misc/funny-manpages/funny-manpages.SlackBuild
parent37274113c3478150aab06ce3db914f6477f4fda7 (diff)
downloadslackbuilds-1ce14296d1cee7c2cc925c94fdcca5de40930d8c.tar.gz
misc/funny-manpages: Added to 12.1 repository
Diffstat (limited to 'misc/funny-manpages/funny-manpages.SlackBuild')
-rw-r--r--misc/funny-manpages/funny-manpages.SlackBuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/misc/funny-manpages/funny-manpages.SlackBuild b/misc/funny-manpages/funny-manpages.SlackBuild
new file mode 100644
index 0000000000..6f71ed08be
--- /dev/null
+++ b/misc/funny-manpages/funny-manpages.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for funny-manpages
+# Copyright 2007-2008 Michiel van Wessem, Manchester, United Kingdom
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=funny-manpages
+VERSION=1.3.5
+SRC_VERSION=1.3
+DEB_VERSION=1.3-5
+
+
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/${PRGNAM}_$SRC_VERSION.orig.tar.gz
+cd $PRGNAM-$SRC_VERSION.orig
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Patch the manpages to the latest version.
+patch -p1 < $CWD/${PRGNAM}_$DEB_VERSION.diff
+
+# Create the directories we need
+mkdir -p $PKG/usr/man/man{1,3,6}
+
+for manpage in $(echo *fun); do
+ section=$(echo $manpage | awk -F. '{print $2}' | colrm 2 4)
+ install -m 0644 $manpage $PKG/usr/man/man$section/$manpage
+done
+
+( cd $PKG/usr/man/man1
+ ln -sf grope.1fun egrope.1fun
+ ln -sf grope.1fun fgrope.1fun
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a debian/README.Debian debian/changelog debian/copyright \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz