summaryrefslogtreecommitdiff
path: root/libraries
diff options
context:
space:
mode:
authorHeinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:08:20 +0200
committerHeinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:08:20 +0200
commit00879087608e2e0c3fc25ef4c1b1f8f12ce1d7c1 (patch)
tree892670aff9e977fc731e55f74219a8353dd84b42 /libraries
parentba18274ab8462bd8f681fb94322548793bb23ef9 (diff)
downloadslackbuilds-00879087608e2e0c3fc25ef4c1b1f8f12ce1d7c1.tar.gz
libraries/urwid: Removed from 13.0 repository
Diffstat (limited to 'libraries')
-rw-r--r--libraries/urwid/LICENSE.gzbin9389 -> 0 bytes
-rw-r--r--libraries/urwid/README17
-rw-r--r--libraries/urwid/slack-desc19
-rw-r--r--libraries/urwid/urwid.SlackBuild72
-rw-r--r--libraries/urwid/urwid.info8
5 files changed, 0 insertions, 116 deletions
diff --git a/libraries/urwid/LICENSE.gz b/libraries/urwid/LICENSE.gz
deleted file mode 100644
index 1ccede98e3..0000000000
--- a/libraries/urwid/LICENSE.gz
+++ /dev/null
Binary files differ
diff --git a/libraries/urwid/README b/libraries/urwid/README
deleted file mode 100644
index 147233def2..0000000000
--- a/libraries/urwid/README
+++ /dev/null
@@ -1,17 +0,0 @@
-Urwid is a console user interface library for Python. It is released under the
-GNU Lesser General Public License and includes many features useful for text
-console application developers:
-* Fluid interface resizing (xterm window resizing / fbset on Linux console)
-* Web application display mode using Apache and CGI
-* Support for UTF-8, simple 8-bit and CJK encodings
-* Multiple text alignment and wrapping modes built-in
-* Ability create user-defined text layout classes
-* Simple markup for setting text attributes
-* Powerful list box that handles scrolling between different widget types
-* List box contents may be managed with a user-defined class
-* Flexible edit box for editing many different types of text
-* Buttons, check boxes and radio boxes
-* Customizable layout for all widgets
-* Easy interface for creating HTML screen shots
-
-Urwid was written by Ian Ward.
diff --git a/libraries/urwid/slack-desc b/libraries/urwid/slack-desc
deleted file mode 100644
index 7c5cdf8a15..0000000000
--- a/libraries/urwid/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-urwid: urwid (python console UI module)
-urwid:
-urwid: Urwid is a console user interface library for Python. It is released
-urwid: under the GNU Lesser General Public License and includes many
-urwid: (too many to list) features useful for text console application
-urwid: developers.
-urwid:
-urwid: Urwid was written by Ian Ward.
-urwid:
-urwid: More info at: http://excess.org/urwid
-urwid:
diff --git a/libraries/urwid/urwid.SlackBuild b/libraries/urwid/urwid.SlackBuild
deleted file mode 100644
index ebb39cfd6f..0000000000
--- a/libraries/urwid/urwid.SlackBuild
+++ /dev/null
@@ -1,72 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for urwid
-
-# Copyright 2009 Andrew Psaltis <ampsaltis@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Modified by Robby Workman <rworkman@slackbuilds.org>
-
-PRGNAM=urwid
-VERSION=0.9.8.4
-ARCH=${ARCH:-noarch}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG $TMP/$PRGNAM-$VERSION
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-tar xfv $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root.root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-# Strip this package's sole library, wherever it might be
-# This package probably isn't really a "noarch" due to this, but oh well
-find $PKG -name "str_util.so" -exec strip --strip-unneeded $PKG 2> /dev/null {} \;
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/examples
-cp -a tutorial.html reference.html $PKG/usr/doc/$PRGNAM-$VERSION
-# Include the code examples. They're pretty small, so they can't hurt, I guess.
-cp -a bigtext.py browse.py calc.py dialog.py edit.py fib.py graph.py tour.py \
- $PKG/usr/doc/$PRGNAM-$VERSION/examples
-# urwid's license (LGPLv2) is not included with the source archive.
-zcat $CWD/LICENSE.gz > $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-${BUILD}$TAG.tgz
diff --git a/libraries/urwid/urwid.info b/libraries/urwid/urwid.info
deleted file mode 100644
index 6a78b67f36..0000000000
--- a/libraries/urwid/urwid.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="urwid"
-VERSION="0.9.8.4"
-HOMEPAGE="http://excess.org/urwid"
-DOWNLOAD="http://excess.org/urwid/urwid-0.9.8.4.tar.gz"
-MD5SUM="28f918c66887d4e470ae0c3535579ad7"
-MAINTAINER="Andrew Psaltis"
-EMAIL="ampsaltis@gmail.com"
-APPROVED="rworkman"