summaryrefslogtreecommitdiff
path: root/libraries
diff options
context:
space:
mode:
authorHeinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:08:01 +0200
committerHeinz Wiesinger <pprkut@slackbuilds.org>2010-05-13 00:08:01 +0200
commit86b33a5edcaefc34ea326e24c8732e6353cd648a (patch)
tree0f32d72d546617dc1ec8ec37383f236782561739 /libraries
parent1326296c14bf3a1abb1b6bc295bf0a1ce55dee48 (diff)
downloadslackbuilds-86b33a5edcaefc34ea326e24c8732e6353cd648a.tar.gz
libraries/gnustep-make: Removed from 13.0 repository
Diffstat (limited to 'libraries')
-rw-r--r--libraries/gnustep-make/README5
-rw-r--r--libraries/gnustep-make/doinst.sh15
-rw-r--r--libraries/gnustep-make/gnustep-make.SlackBuild79
-rw-r--r--libraries/gnustep-make/gnustep-make.info8
-rw-r--r--libraries/gnustep-make/slack-desc19
5 files changed, 0 insertions, 126 deletions
diff --git a/libraries/gnustep-make/README b/libraries/gnustep-make/README
deleted file mode 100644
index 696dfda084..0000000000
--- a/libraries/gnustep-make/README
+++ /dev/null
@@ -1,5 +0,0 @@
-The GNUstep Makefile Package is a configuration system and set of rules that
-makes compilation of GNUstep source as easy as simply listing the files.
-
-Before compiling and/or running any other GNUstep based software, the file
-"/usr/share/GNUstep/Makefiles/GNUstep.sh" should be sourced.
diff --git a/libraries/gnustep-make/doinst.sh b/libraries/gnustep-make/doinst.sh
deleted file mode 100644
index 60f3167d48..0000000000
--- a/libraries/gnustep-make/doinst.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-config etc/GNUstep/GNUstep.conf.new
-
diff --git a/libraries/gnustep-make/gnustep-make.SlackBuild b/libraries/gnustep-make/gnustep-make.SlackBuild
deleted file mode 100644
index ab4d8d8309..0000000000
--- a/libraries/gnustep-make/gnustep-make.SlackBuild
+++ /dev/null
@@ -1,79 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for GNUstep's make package.
-
-# Written by Stefan Bidigaray
-
-PRGNAM=gnustep-make
-VERSION=2.0.7
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-# Optional Parameter
-FS_LAYOUT=${FS_LAYOUT:-fhs-system}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCLAGS" \
-./configure \
- --enable-strip-makefiles \
- --with-layout=$FS_LAYOUT
-
-make
-make install DESTDIR=$PKG
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
-)
-
-# Put the man pages in the correct place
-mv $PKG/usr/share/man $PKG/usr
-
-# Fixup a few paths in the GNUstep.conf
-sed -i 's|/usr/share/man|/usr/man|g' $PKG/etc/GNUstep/GNUstep.conf
-sed -i 's|/usr/local/share/man|/usr/local/man|g' $PKG/etc/GNUstep/GNUstep.conf
-sed -i 's|/usr/share/info|/usr/info|g' $PKG/etc/GNUstep/GNUstep.conf
-sed -i 's|/usr/local/share/info|/usr/local/info|g' $PKG/etc/GNUstep/GNUstep.conf
-
-# Don't clobber the config file on upgrades
-mv $PKG/etc/GNUstep/GNUstep.conf $PKG/etc/GNUstep/GNUstep.conf.new
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING README NEWS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -c n -l y $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/gnustep-make/gnustep-make.info b/libraries/gnustep-make/gnustep-make.info
deleted file mode 100644
index 548e0c62db..0000000000
--- a/libraries/gnustep-make/gnustep-make.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="gnustep-make"
-VERSION="2.0.7"
-HOMEPAGE="http://www.gnustep.org"
-DOWNLOAD="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-make-2.0.7.tar.gz"
-MD5SUM="13bd26f135cbc38a94dfb220e9ffd460"
-MAINTAINER="Stefan Bidigaray"
-EMAIL="teco.sb@gmail.com"
-APPROVED="rworkman"
diff --git a/libraries/gnustep-make/slack-desc b/libraries/gnustep-make/slack-desc
deleted file mode 100644
index eb1d555685..0000000000
--- a/libraries/gnustep-make/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------|
-gnustep-make: gnustep-make (GNUstep Make package)
-gnustep-make:
-gnustep-make: GNUstep is a cross-platform, object-oriented framework for
-gnustep-make: desktop applicaiton development. It is based on the OPENSTEP
-gnustep-make: specification originally published by NeXT (now Apple).
-gnustep-make: The GNUstep Make package is required in order to build any
-gnustep-make: GNUstep-based software.
-gnustep-make:
-gnustep-make: GNUstep is part of the official GNU project.
-gnustep-make: Homepage: http://www.gnustep.org
-gnustep-make: