summaryrefslogtreecommitdiff
path: root/libraries/pyusb
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committerRobby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /libraries/pyusb
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries/pyusb')
-rw-r--r--libraries/pyusb/README3
-rw-r--r--libraries/pyusb/pyusb.SlackBuild75
-rw-r--r--libraries/pyusb/pyusb.info10
-rw-r--r--libraries/pyusb/slack-desc19
4 files changed, 0 insertions, 107 deletions
diff --git a/libraries/pyusb/README b/libraries/pyusb/README
deleted file mode 100644
index c93b48b72b..0000000000
--- a/libraries/pyusb/README
+++ /dev/null
@@ -1,3 +0,0 @@
-PyUSB is a native Python module written in C which provides easy USB access
-to Python. The module contains classes and methods to support most USB
-operations.
diff --git a/libraries/pyusb/pyusb.SlackBuild b/libraries/pyusb/pyusb.SlackBuild
deleted file mode 100644
index c7b73e018b..0000000000
--- a/libraries/pyusb/pyusb.SlackBuild
+++ /dev/null
@@ -1,75 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pyusb
-# Written by Kyle Guinn <elyk03@gmail.com>
-
-PRGNAM=pyusb
-VERSION=${VERSION:-0.4.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM-$VERSION
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="PKG-INFO README license.txt"
-
-if [ $ARCH = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ $ARCH = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ $ARCH = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-python ./setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# Normalize line endings
-sed -i "s/\xd$//g" README
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pyusb/pyusb.info b/libraries/pyusb/pyusb.info
deleted file mode 100644
index 09b9b8432c..0000000000
--- a/libraries/pyusb/pyusb.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyusb"
-VERSION="0.4.1"
-HOMEPAGE="http://pyusb.berlios.de/"
-DOWNLOAD="http://downloads.sourceforge.net/pyusb/pyusb-0.4.1.tar.gz"
-MD5SUM="9576c3e471e40e021fa44f36712bbd04"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Kyle Guinn"
-EMAIL="elyk03@gmail.com"
-APPROVED="dsomero"
diff --git a/libraries/pyusb/slack-desc b/libraries/pyusb/slack-desc
deleted file mode 100644
index 6062d08814..0000000000
--- a/libraries/pyusb/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-pyusb: PyUSB (USB module for Python)
-pyusb:
-pyusb: PyUSB is a native Python module written in C which provides easy USB
-pyusb: access to Python. The module contains classes and methods to
-pyusb: support most USB operations.
-pyusb:
-pyusb:
-pyusb:
-pyusb:
-pyusb:
-pyusb: