summaryrefslogtreecommitdiff
path: root/libraries/pytables/pytables.SlackBuild
diff options
context:
space:
mode:
authorLukenShiro <lukenshiro@ngi.it>2010-12-10 00:12:23 -0200
committerRobby Workman <rworkman@slackbuilds.org>2010-12-12 15:47:14 -0600
commit1b976ec966c382b49e1aeade87cb19aee485175d (patch)
treead4e8fb6d117f0b351cd7865aa12f4b2c8b9e213 /libraries/pytables/pytables.SlackBuild
parent13b19c3ff3f5fcfa071909cb2bd68a2b0092f6c1 (diff)
downloadslackbuilds-1b976ec966c382b49e1aeade87cb19aee485175d.tar.gz
libraries/pytables: Updated for version 2.2.
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'libraries/pytables/pytables.SlackBuild')
-rw-r--r--libraries/pytables/pytables.SlackBuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/libraries/pytables/pytables.SlackBuild b/libraries/pytables/pytables.SlackBuild
index 5e804fdb71..27c070852d 100644
--- a/libraries/pytables/pytables.SlackBuild
+++ b/libraries/pytables/pytables.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pytables
-# Copyright 2007-2009 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2007-2010 LukenShiro <lukenshiro@ngi.it>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,16 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pytables
-VERSION=${VERSION:-2.1.2}
+VERSION=${VERSION:-2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -70,9 +68,13 @@ rm -rf $SRC_PRGNAM-$VERSION
tar xvf $CWD/$SRC_PRGNAM-$VERSION.tar.gz
cd $SRC_PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
-python setup.py install --prefix=/usr --root=$PKG
+CFLAGS="$SLKCFLAGS" python setup.py build install --prefix=/usr --root=$PKG
# Copy examples, contrib, and bench files
mkdir -p $PKG/usr/share/$PRGNAM/
@@ -86,7 +88,7 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc