summaryrefslogtreecommitdiff
path: root/libraries/pyPdf
diff options
context:
space:
mode:
authorRobby Workman <rworkman@slackbuilds.org>2011-03-16 01:13:49 -0500
committerRobby Workman <rworkman@slackbuilds.org>2011-03-20 12:33:01 -0500
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /libraries/pyPdf
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries/pyPdf')
-rw-r--r--libraries/pyPdf/README12
-rw-r--r--libraries/pyPdf/pyPdf.SlackBuild76
-rw-r--r--libraries/pyPdf/pyPdf.info10
-rw-r--r--libraries/pyPdf/slack-desc19
4 files changed, 0 insertions, 117 deletions
diff --git a/libraries/pyPdf/README b/libraries/pyPdf/README
deleted file mode 100644
index 50e3c592a6..0000000000
--- a/libraries/pyPdf/README
+++ /dev/null
@@ -1,12 +0,0 @@
-A Pure-Python library built as a PDF toolkit. It is capable of:
- * extracting document information (title, author, ...),
- * splitting documents page by page,
- * merging documents page by page,
- * cropping pages,
- * merging multiple pages into a single page,
- * encrypting and decrypting PDF files.
-
-By being Pure-Python, it should run on any Python platform without any
-dependencies on external libraries. It can also work entirely on StringIO
-objects rather than file streams, allowing for PDF manipulation in memory. It is
-therefore a useful tool for websites that manage or manipulate PDFs.
diff --git a/libraries/pyPdf/pyPdf.SlackBuild b/libraries/pyPdf/pyPdf.SlackBuild
deleted file mode 100644
index 124da91835..0000000000
--- a/libraries/pyPdf/pyPdf.SlackBuild
+++ /dev/null
@@ -1,76 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pyPdf.
-#
-# Copyright 2009-2010 Marco Bonetti <sid77@slackware.it>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pyPdf
-VERSION=1.12
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="PKG-INFO README"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pyPdf/pyPdf.info b/libraries/pyPdf/pyPdf.info
deleted file mode 100644
index 0ab66057ff..0000000000
--- a/libraries/pyPdf/pyPdf.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyPdf"
-VERSION="1.12"
-HOMEPAGE="http://pybrary.net/pyPdf/"
-DOWNLOAD="http://pybrary.net/pyPdf/pyPdf-1.12.tar.gz"
-MD5SUM="7be5f7f4659f64fd194e9eb9a38ad425"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Marco Bonetti"
-EMAIL="sid77@slackware.it"
-APPROVED="dsomero"
diff --git a/libraries/pyPdf/slack-desc b/libraries/pyPdf/slack-desc
deleted file mode 100644
index 5417a1afc3..0000000000
--- a/libraries/pyPdf/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-pyPdf: pyPdf (Python PDF toolkit)
-pyPdf:
-pyPdf: A Pure-Python library built as a PDF toolkit.
-pyPdf:
-pyPdf:
-pyPdf:
-pyPdf:
-pyPdf:
-pyPdf:
-pyPdf:
-pyPdf: