summaryrefslogtreecommitdiff
path: root/libraries/miniupnpc/miniupnpc.SlackBuild
diff options
context:
space:
mode:
authorLarry Hajali <larryhaja[at]gmail[dot]com>2013-05-19 09:12:09 -0400
committerdsomero <xgizzmo@slackbuilds.org>2013-05-19 09:12:09 -0400
commit0fa725094732c3bb45d94cdb90374c46480bd04d (patch)
tree7d70daa1da6d2698ebdc6ebe2804ad0949f33ccd /libraries/miniupnpc/miniupnpc.SlackBuild
parent155f4dceb481fc6995a33038e7a3349278f09533 (diff)
downloadslackbuilds-0fa725094732c3bb45d94cdb90374c46480bd04d.tar.gz
libraries/miniupnpc: Updated for version 1.8.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'libraries/miniupnpc/miniupnpc.SlackBuild')
-rw-r--r--libraries/miniupnpc/miniupnpc.SlackBuild37
1 files changed, 32 insertions, 5 deletions
diff --git a/libraries/miniupnpc/miniupnpc.SlackBuild b/libraries/miniupnpc/miniupnpc.SlackBuild
index e910674036..d885afaeb3 100644
--- a/libraries/miniupnpc/miniupnpc.SlackBuild
+++ b/libraries/miniupnpc/miniupnpc.SlackBuild
@@ -2,10 +2,28 @@
# Slackware build script for miniupnpc
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=miniupnpc
-VERSION=${VERSION:-1.7}
+VERSION=${VERSION:-1.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -53,14 +71,23 @@ find . \
# Slackware/Slackbuilds.org specific info.
patch -p1 < $CWD/slackware-version.patch
-sed -i -e "/^CFLAGS/ s|-O|$SLKCFLAGS|" -e 's|share/man|man|' Makefile
+sed -i 's|share/man|man|' Makefile
+sed -i -e 's|\.a"|\.so"|' -e "s|version=\".*\"|version=\"$VERSION\"|" setup.py
# Upstream Cmake causes build problems. We're going to use the makefile instead.
-make
-make install PREFIX=$PKG INSTALLDIRLIB="$PKG/usr/lib$LIBDIRSUFFIX"
+CFLAGS="$SLKCFLAGS" LIBDIR="lib${LIBDIRSUFFIX}" make
+make install PREFIX=$PKG LIBDIR="lib${LIBDIRSUFFIX}"
+CFLAGS="$SLKCFLAGS" \
python setup.py install --root=$PKG
+# For python 3.x support.
+if `python3 -c 'import distutils' 2>/dev/null`; then
+ CFLAGS="$SLKCFLAGS" \
+ python3 setup.py build
+ python3 setup.py install --root=$PKG --no-compile
+fi
+
# Remove static library.
rm -f $PKG/usr/lib$LIBDIRSUFFIX/lib$PRGNAM.a