summaryrefslogtreecommitdiff
path: root/libraries/luasec/luasec.SlackBuild
diff options
context:
space:
mode:
authorAndrew Tkalia <anddt@yandex.ua>2014-05-18 20:35:15 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2014-05-18 20:35:15 +0700
commitfb2c6a0e446be7c120a4907887c65ee79b05412d (patch)
tree6b3ed3dcb27902a1070b8c344cd824a09949a216 /libraries/luasec/luasec.SlackBuild
parent6fb1d14b9940164a21ef9cac2468eafb5457c9c4 (diff)
downloadslackbuilds-fb2c6a0e446be7c120a4907887c65ee79b05412d.tar.gz
libraries/luasec: Updated for version 20140421_903efaf.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/luasec/luasec.SlackBuild')
-rw-r--r--libraries/luasec/luasec.SlackBuild35
1 files changed, 17 insertions, 18 deletions
diff --git a/libraries/luasec/luasec.SlackBuild b/libraries/luasec/luasec.SlackBuild
index 603f9506a1..05f705b97a 100644
--- a/libraries/luasec/luasec.SlackBuild
+++ b/libraries/luasec/luasec.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for luasec
-# Copyright 2013, Andrew Tkalia <anddt@yandex.ru>, Ukraine, Kyiv
+# Copyright 2013-2014, Andrew Tkalia <anddt@yandex.ua>, Ukraine, Kyiv
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=luasec
-VERSION=${VERSION:-0.4.1}
+HASH=${HASH:-903efaf3b1f090a992963480fa2924dac02f9174}
+VERSION=20140421_$(echo $HASH |cut -c -7)
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -47,7 +48,7 @@ elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
+ SLKCFLAGS="-O2"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
@@ -59,25 +60,24 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$PRGNAM-$VERSION
+rm -rf $PRGNAM-$HASH
+tar xvf $CWD/$HASH.tar.gz
+cd $PRGNAM-$HASH
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
cd src
-# Getting default cflags from config then append slkcflags to them and passing to make
-_CFLAGS=`cat Makefile |grep ^LNX_CFLAGS |sed "s,LNX_CFLAGS\=,,g"`" "${SLKCFLAGS}
-_DEFS=`cat ../Makefile |grep ^DEFS |sed "s,DEFS\=,,g"`
+ patch < $CWD/makefile.patch
+cd -
+
make linux \
- LUAPATH=/usr/share/lua/5.1 \
- LUACPATH=/usr/lib${LIBDIRSUFFIX}/lua/5.1 \
- DEFS="$_DEFS" \
- LNX_CFLAGS=" $_CFLAGS"
+ LUACPATH="/usr/lib${LIBDIRSUFFIX}/lua/5.1" \
+ LIB_PATH=" -L/usr/lib${LIBDIRSUFFIX}" \
+ SLKCFLAGS="${SLKCFLAGS}"
mkdir -p $PKG/usr/share/lua/5.1
mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/lua/5.1
@@ -85,7 +85,6 @@ mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/lua/5.1
make install \
LUAPATH=$PKG/usr/share/lua/5.1 \
LUACPATH=$PKG/usr/lib${LIBDIRSUFFIX}/lua/5.1
-cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true