summaryrefslogtreecommitdiff
path: root/libraries/CSparse/autotoolize.diff
diff options
context:
space:
mode:
authorKyle Guinn <elyk03@gmail.com>2011-05-31 21:49:31 -0400
committerRobby Workman <rworkman@slackbuilds.org>2011-06-13 01:31:21 -0400
commit4f98c71e040464177b6d8e6152da0a06e3eef924 (patch)
treea3cef21e72fa6e544668a16bca1ea9e7ac3500dc /libraries/CSparse/autotoolize.diff
parentcece546129c2819a463f7d38dac21ed3bc1586cf (diff)
downloadslackbuilds-4f98c71e040464177b6d8e6152da0a06e3eef924.tar.gz
libraries/CSparse: Updated for version 2.2.5.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'libraries/CSparse/autotoolize.diff')
-rw-r--r--libraries/CSparse/autotoolize.diff39
1 files changed, 32 insertions, 7 deletions
diff --git a/libraries/CSparse/autotoolize.diff b/libraries/CSparse/autotoolize.diff
index 688a5a3a5b..116e15d3e9 100644
--- a/libraries/CSparse/autotoolize.diff
+++ b/libraries/CSparse/autotoolize.diff
@@ -49,16 +49,23 @@ new file mode 100644
+ -./cs_demo2 < ../Matrix/bcsstk16
+ -./cs_demo3 < ../Matrix/bcsstk01
+ -./cs_demo3 < ../Matrix/bcsstk16
+diff --git a/Include/Makefile.am b/Include/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Include/Makefile.am
+@@ -0,0 +1,2 @@
++pkgincludedir = $(includedir)/csparse
++pkginclude_HEADERS = cs.h
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,5 @@
-+SUBDIRS = Source Matrix Demo
++SUBDIRS = Include Source Matrix Demo
+EXTRA_DIST = README.txt Doc/ChangeLog Doc/License.txt Doc/lesser.txt
+
-+pkgincludedir = $(includedir)/csparse
-+pkginclude_HEADERS = Include/cs.h
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = csparse.pc
diff --git a/Matrix/Makefile.am b/Matrix/Makefile.am
new file mode 100644
--- /dev/null
@@ -141,14 +148,14 @@ new file mode 100644
+lib_LTLIBRARIES = libcsparse.la
+libcsparse_la_SOURCES = $(CSPARSESRC)
+libcsparse_la_LIBADD = -lm
-+libcsparse_la_LDFLAGS = -no-undefined -version-info 4:4:2
++libcsparse_la_LDFLAGS = -no-undefined -version-info 4:5:2
diff --git a/configure.ac b/configure.ac
new file mode 100644
--- /dev/null
+++ b/configure.ac
-@@ -0,0 +1,30 @@
-+AC_PREREQ([2.65])
-+AC_INIT([CSparse], [2.2.4], [davis@cise.ufl.edu])
+@@ -0,0 +1,32 @@
++AC_PREREQ([2.68])
++AC_INIT([CSparse],[2.2.5],[davis@cise.ufl.edu])
+AC_CONFIG_SRCDIR([Source/cs_print.c])
+AC_CONFIG_HEADER([config.h])
+AM_INIT_AUTOMAKE([foreign])
@@ -172,8 +179,26 @@ new file mode 100644
+LIBS=$LIBS_SAVED
+
+AC_CONFIG_FILES([
++ csparse.pc
+ Makefile
+ Demo/Makefile
++ Include/Makefile
+ Matrix/Makefile
+ Source/Makefile])
+AC_OUTPUT
+diff --git a/csparse.pc.in b/csparse.pc.in
+new file mode 100644
+--- /dev/null
++++ b/csparse.pc.in
+@@ -0,0 +1,11 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: @PACKAGE_NAME@
++Description: A concise sparse matrix package
++Version: @PACKAGE_VERSION@
++Libs: -L${libdir} -lcsparse
++Libs.private: -lm
++Cflags: -I${includedir}/csparse