summaryrefslogtreecommitdiff
path: root/gis/pyproj/pyproj.SlackBuild
diff options
context:
space:
mode:
authorBenjamin Trigona-Harany <bosth@alumni.sfu.ca>2019-03-12 21:16:03 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2019-03-16 06:53:29 +0700
commitc1573cde1ab37bd44f7908335f5fc620f85f118d (patch)
tree6410f2d4dc47fcd63e8be0496ef906438e14d63d /gis/pyproj/pyproj.SlackBuild
parente402b166a303d951b145789ea89094cd0a869f3a (diff)
downloadslackbuilds-c1573cde1ab37bd44f7908335f5fc620f85f118d.tar.gz
gis/pyproj: Fix build for Python 3.7.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'gis/pyproj/pyproj.SlackBuild')
-rw-r--r--gis/pyproj/pyproj.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/gis/pyproj/pyproj.SlackBuild b/gis/pyproj/pyproj.SlackBuild
index 62bb864a1a..7d8a88df92 100644
--- a/gis/pyproj/pyproj.SlackBuild
+++ b/gis/pyproj/pyproj.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyproj
-# Copyright 2013-2018 Benjamin Trigona-Harany
+# Copyright 2013-2019 Benjamin Trigona-Harany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=pyproj
VERSION=${VERSION:-1.9.6}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,8 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true